Rclone reveal error

What is the problem you are having with rclone?

I tried to reveal a password of an old config file of mine. Until now I just copied the obfusicated version, which works fine (so the obfusicated version is valid). However, I like to have the password back.

The obfusicated version starts with "-" but is still a valid base64 string. The reveal command interprets that as a shorthand flag: Fatal error: unknown shorthand flag: '9' in -9******

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: debian 11.6 (64 bit)
  • os/kernel: 5.15.83-1-pve (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive with Crypt.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

# password is replaced with "..."
rclone reveal "-9..."

Also tried

# password is replaced with '...'
rclone reveal '-9...'

A log from the command with the -vv flag

Same as before.

Change that to

rclone reveal '\-9...'

That worked for me without issue.

That also doesn't work. It's now not recognized as a flag but marked as invalid base64. But the decryption/encryption is working and I also tested the string with other tools: it's valid.
Failed to reveal: base64 decode failed when revealing password - is it obscured?: illegal base64 data at input byte 0

I think this is the right rune - use -- to tell the command parser that there are no more flags coming.

$ rclone reveal -- "-7JmsbkHgHu7qgqEnMH4qoup9OI"
1 Like

I do remember that double dash now after seeing it!

Thanks for reminding me that exists as I stumbled on this type of issue one time many years back..

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.