Rclone remote and using local disk

What is the problem you are having with rclone?

I have an rclone running in remote control mode (on a QNAP nas, using a QNAP package), and I want to transfer data from a local disk to a Minio remote. In the rclone UI I can access and see the Minio remote just fine, but when I use the rclone UI browser to browse the local disk, I can only access a specific folder (the installation folder, it seems) and not access the disk I need (which is somewhere in /share).

How can I change rclone rc to use the proper path instead of the current one?

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.0
- os/version: unknown
- os/kernel: 5.10.60-qnap (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.19.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Local storage and S3

The command you were trying to run (eg rclone copy /tmp remote:tmp)

curl --user user:pass -H "Content-Type: application/json" -X POST --data @rclone-rc.json "http://qnap-nas:5572/sync/copy"

with the following JSON:

{
	"dstFs": "s3:bucket/folder1/folder3/folder3/",
	"srcFs": "local:/share/CACHEDEV8_DATA/",
	"_async": true,
	"transfers": 8,
	"checkers": 8
}

The rclone config contents with secrets removed.

[s3]
type = s3
access_key_id = my-access-key
endpoint = http://minio:9000/
provider = Minio
region = my-region
secret_access_key = my-secret

[local]
type = local

A log from the command with the -vv flag

Not available, we run it through the API, not the commandline. Here's the output from the job:

{
	"duration": 0.008929969,
	"endTime": "2023-01-04T11:42:44.568956874+01:00",
	"error": "",
	"finished": true,
	"group": "job/6471",
	"id": 6471,
	"output": {},
	"startTime": "2023-01-04T11:42:44.560026904+01:00",
	"success": true
}

To partially answer my own question: in the QNAP start/stop script there was this:

QPKG_ROOT=/share/CACHEDEV1_DATA/.qpkg/RClone
cd $QPKG_ROOT
rclone rcd --rc-web-gui --rc-addr=0.0.0.0:5572 --rc-user qnap --rc-pass qnap --rc-web-gui-update &

This lead rclone to start with the installation folder (/share/CACHEDEV1_DATA/.qpkg/RClone) as the root folder for a local remote.

I changed the startup script to this:

cd /share
$QPKG_ROOT/rclone rcd --rc-web-gui --rc-addr=0.0.0.0:5572 --rc-user qnap --rc-pass qnap --rc-web-gui-update &

And now I can at least use the file browser to navigate to the disks in /share. It's not very elegant and I would like to prefer to set this with a configuration parameter somewhere so I can keep using the QNAP package on my devices (multiple of them) rather than having to patch it manually after each upgrade.