Rclone rcd --rc-web-gui error ubuntu 18.04

I am getting errors with rclone's web ui command.. fresh install through the ubuntu apt get rclone.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04

`root@Ubuntu-1804-bionic-64-minimal ~/AutoRclone # rclone rcd --rc-web-gui
Error: unknown command "rcd" for "rclone"

Did you mean this?

Run 'rclone --help' for usage`


log file just gives me the standard --help info...

hello and welcome to the forum,

the latest stable is v1.53.1.

ubuntu's and all other repositories are always very out of date.

this is the the only way to keep rclone up to date.

That version is back from when the dinosaurs ruled the Earth.

You'd want to get the latest.

I have reinstalled the updated to the 1.53.1 manually.. can't use curl on my setup...

The web gui started without an error on server but browser can't get it open.. I tried resetting the ip address but it's giving this error
rclone rcd --rc-web-gui --rc-addr=xx.xx.xx.xx:5572 --rc-user=admin --rc-pass=adminadmin --rc-serve
2020/10/11 18:27:52 NOTICE: Web GUI exists. Update skipped.
2020/10/11 18:27:52 NOTICE: Serving Web GUI
2020/10/11 18:27:52 Failed to start remote control: start server failed: listen tcp x.x.x.x:5572: bind:
cannot assign requested address

It's not working with oauth on google btw.. not sure what that issue is. I installed the google api auth directly from the google install git string...

That means you already have something running on the port and you need to pick a different one.

There's nothing additional that needs to be installed to authorize your account. You'd have to share more details and what you did.

I enabled all the api's needed. I created the project/oauth credentials.json I have used it to copy a folder from one team drive to another using the autoRclone (after I copied my credentials.json file over and all the service accounts to the dedicated server so I know the credentials work. I have even done the oauth on my windows copy of rclone and that works.. I even went onto my rdp vps windows machine and it worked there... Ubuntu with rclone just doesn't want to authorize.

Side note I got the web gui working. Had to open the port open.

I'm having same issue on the auth problems on google drive via the web. It doesn't open up the pop up for me to authorize connection... gives me

error creating config. error: network error

You’d have to share a full log as looks like a networking issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.