Rclone, Qnap and Plex

Hi guys,

So ive installed Rclone 1.54.1 (From qnap club) on my Qnap Nas system.

Then I installed Putty on my computer and managed to setup a new remote to Sharefile.

Then after I run the command: rclone mount nameofmount: /share/CACHEDEV1_DATA/Test1 --allow-non-empty

And everything worked perfectly. Now 24 hours later my qnap system is so slow that i had to restart it.

Then after the restart the mount and the remote i setup before is gone.

could anyone try help me with this?

if you want rclone mount to run at startup, you have to set that up yourself.
Running Your Own Application at Startup - QNAPedia

about the slow system, what is making it slow, cpu, memory or what?
there are many guides on the internet, to help figure out what is making the qnap system slow.

run rclone with a debug log and when the systems slows down, look into that.

OK understand. Now i have a new issue suddenly. when i what to authorize an remote. on http://127.0.0.1:53682 it just get ERR_CONNECTION_REFUSED

Ive alos tried to do it it remotely,,,,,,,,... i get to add my log in details. then it redirects to > http://127.0.0.1:53682/?code=EQAPD9LHQxWOjBueyVga07UUCiBVlbk1&state=AF9rne-zo02xDjS3bgD3pA&subdomain=the&apicp=sharefile.com&appcp=sharefile.com&++++++

and again i get an ERR_CONNECTION_REFUSED

whats going on there?

not sure what you are trying to do?

what command are you running?

for the remote setup, you are folllowiing these steps?
Remote Setup

for some reason i cant do the athorize on my qnap nas browser. So yeah i followed the steps and did run the command. rclone athorize "sharefile" on my windows 10 computer

The share file login pops up i put my details and then it redirects to. http://127.0.0.1:53682/?code=EQAPD9LHQxWOjBueyVga07UUCiBVlbk1&state=AF9rne-zo02xDjS3bgD3pA&subdomain=the&apicp=sharefile.com&appcp=sharefile.com&++++++

And i get this site cant be reached
ERR_CONNECTION_REFUSED

not sure why perhaps a web browser issue.
what web browser are you using?

as a workaround,
you can create the remote on windows and copy that config file to the qnap.

It might be a local firewall issue. Rclone runs a webserver locally temporarily to receive the reply back from the oauth - this might be blocked by a local firewall.

I actually found out i had to remove my apps on sharefile for it to work again.

Update: Now i have gotten it to work. But my issue now is when my qnap update or restarts i have to do it all over again.

Is there away to make rclone start automaticly and mount automaticly?

hi,

at the top of the post, i shared a link about that...