Rclone puts files in same folder as itself

I can't get rclone to put files in desired local location and rclone.
When I run the commands provided below it puts the files in the same folder as rclone within a new folder with the name local/alias.

rclone version output:

rclone v1.57.0
- os/version: Microsoft Windows 10 Pro 2009 (64 bit)
- os/kernel: 10.0.19044.1526 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.17.2
- go/linking: dynamic
- go/tags: cmount

I'm not using a cloud remote, I want to put files on a local drive (network drive within home, share mounted as drive).

I've tried multiple commands and nothing works. These two will not encrypt the content as puts it in a subfolder of the rclone directory:

rclone sync e: encryptednasbackuplocal

rclone sync e: encryptednasbackupalias

These two will encrypt the content but still puts the content within a subfolder within the rclone directory:

rclone sync e: encryptednasbackupalias:

rclone sync e: encryptednasbackupalias:Z:\Backup\

I've tried with this config:

type = local

type = alias
remote = "Z:\Backup\"

type = crypt
remote = nasbackuplocal:Z:\Backup\
password = ***
password2 = ***

type = crypt
remote = nasbackupalias
password = ***
password2 = ***

Here is an excert with the -vv flag, every single line looks like this except with different paths and hashes:

2022/02/10 13:20:04 DEBUG : Files/.Net Framework/NET 3.5 - dotnetfx35.exe: md5 = d481cda2625d9dd2731a00f482484d86 OK

You need to reference remotes with a ":" after them so

needs to be:

type = crypt
remote = nasbackupalias:
password = ***
password2 = ***

Test with rclone ls on your remote and see if it shows what you'd expect.

Thank you a ton! Such an easy oversight :sweat_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.