Rclone problem with bunny cdn

i normally use rsync to copy files

now i am trying to copy files from my server to bunnycdn ftp
this is my rclone.conf
type = ftp
host = la.storage.bunnycdn.com
user = loidrivers
port = 21
pass = 3d58b8ca-4a18-54a43-698ca94c2fe9d14-31b2-428b

pass = 1234567890123456789012

when run rclone ls lodrivers: -vv --dump bodies
i get

2024/02/01 11:45:22 DEBUG : rclone: Version "v1.65.2" starting with parameters ["rclone" "ls" "loidrivers:" "-vv" "--dump" "bodies"]
2024/02/01 11:45:22 DEBUG : Creating backend with remote "loidrivers:"
2024/02/01 11:45:22 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2024/02/01 11:45:22 DEBUG : ftp://la.storage.bunnycdn.com:21: Connecting to FTP server
2024/02/01 11:45:22 DEBUG : ftp://la.storage.bunnycdn.com:21: dial("tcp","la.storage.bunnycdn.com:21")
2024/02/01 11:45:22 DEBUG : ftp://la.storage.bunnycdn.com:21: > dial: conn=*fshttp.timeoutConn, err=<nil>
2024/02/01 11:45:22 DEBUG : FTP Rx: "220 Service Ready."
2024/02/01 11:45:22 DEBUG : FTP Tx: "USER loidrivers"
2024/02/01 11:45:22 DEBUG : FTP Rx: "331 Username ok, need password"
2024/02/01 11:45:22 DEBUG : FTP Tx: PASS *****
2024/02/01 11:45:22 DEBUG : FTP Rx: "530 Not logged in"
2024/02/01 11:45:22 DEBUG : FTP Rx: "BYE"
2024/02/01 11:45:22 DEBUG : FTP Tx: "QUIT"
2024/02/01 11:45:22 Failed to create file system for "loidrivers:": NewFs: failed to make FTP connection to "la.storage.bunnycdn.com:21": 530 Not logged in

don't know whats the problem please help

server refuses your credentials.

Have you created your remote using rclone config? or manually?

Please note that pass value has to be obscured. If you want to add it manually you have to run:

$ rclone obscure password

and use generated string as your password in config file.

when i run

rclone obscure password

i got `root@hostname:~# rclone obscure password

type = ftp
host = la.storage.bunnycdn.com
user = logidrivers
port = 21
pass = f840c3bc-6d53-4e15-b59e48df6-a095-4337

pass = 89WUSK9OjVF-hD1IgFxyYP0ZGj3fb_RF``
now i have this as configuration still it is showing same error

can you post

rclone config redacted logidrivers:

root@hostname:~# rclone config redacted logidrivers:
type = ftp
host = XXX
user = XXX
port = 21
pass = XXX
### Double check the config for sensitive info before posting publicly

ok. Try to connect using these user/pass using different ftp client. FileZilla or whatever you prefer. It will validate if you have correct credentials.

please help not able to understand the problem

It looks like you are using wrong password in rclone config file. Delete it and run rclone config and create this remote again.

can you try from your end i will give ftp details

no problem. Contact me using priv message

hi now it connects but file not upload completely

share -vv log

partial: partial file rename failed: Move Rename failed: 450 Requested file action not taken

add --inplace flag to your copy/sync/move command


rclone copy /home/admin/web/mydomain.com/public_html logidrivers:logidrivers --inplace

should make a trick

rclone copy /home/admin/web/mydomain.com/public_html/ logidrivers:logidrivers/
this is the command i used to copy

rclone copy /home/admin/web/mydomain.com/public_html logidrivers:logidrivers --inplace
tried but nothing happens

Sorry what you mean nothing happens? Probably things were transferred and it finished.

You can always run with -vv flag to see DEBUG detailed output:

rclone copy /home/admin/web/mydomain.com/public_html logidrivers:logidrivers --inplace -vv

tried but gives error

post all output here - so somebody can see what might be wrong