Rclone ppc64le precompiled


is there any possibility to have a pre compiled rclone copy for ppc64le to use on clusters?

None of the method on the installation page has worked so far for various reasons and limitations


You should be able to cross compile a ppc64le version like this anywhere you have Go installed.

$ git clone https://github.com/rclone/rclone.git 
Cloning into 'rclone'...

$ cd rclone
$ GOOS=linux GOARCH=ppc64le go build

$ file rclone
rclone: ELF 64-bit LSB executable, 64-bit PowerPC or cisco 7500, OpenPOWER ELF V2 ABI, version 1 (SYSV), statically linked, Go BuildID=jfaeDq5TCyEdFvxcOnZ7/rSec_ia1Nk4QZt3VSOJR/neR7QZKWl6JoQB4f6cSX/1F8toGg1sUWoriMDmYis, with debug_info, not stripped

I uploaded the result of that for you to try here: https://pub.rclone.org/rclone-linux-ppc64le.v1.63.0-beta.7033.fcf47a839.gz

Hi @ncw

thanks for the quick reply.
My issue is that I cannot install go on my architecture and I need a precompiled version of rclone for this... Is there any possibility to get it? It would be immensely useful...


You don't need to - you can cross compile it using the instructions I gave above.

I made one for you above

I think I'm doing something wrong:

I have done:

wget https://pub.rclone.org/rclone-linux-ppc64le.v1.63.0-beta.7033.fcf47a839.gz

gunzip rclone-linux-ppc64le.v1.63.0-beta.7033.fcf47a839.gz

alias rclone=/home/rclone-linux-ppc64le.v1.63.0-beta.7033.fcf47a839

rclone config 

but tells me:

permission denied

I do apologise for the dumb issue with the install...

You probably need to have execute permissions on the binary.

chmod u+x rclone binary file

1 Like

Everything works like a charm!

One last question: I have to configure it to upload to a shared drive on google drive. How it can be setted up? At the moment it only uploads stuff to my personal drive


Would be best to make a new post and use the help and support template and fill it out.

1 Like

Just solved, I had to accept to configure as a shared drive.

Once again, super grateful for the help provided!! Thanks a lot!!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.