Rclone pauses randomly until I press enter

Sometimes rclone will just get stuck with no indication that the upload is paused. Until I press a key on the keyboard it is silently stuck. How can I prevent this, and why does it do this?

rclone 1.47
windows 10 x64 build 1903
this has happened on every version and pc for the past year
google drive and I believe onedrive as well.

"C:\self-contained programs\rclone-v1.47.0-windows-amd64\rclone.exe" copy "n:\Videos" "remotename:videos" -L -vv

I'll copy the output next pause but there was no indication that anything was pending or resolved after pressing a key. (Except that the scrolling text continues and the uploads pick up from where they left off).

hello and welcome to the forum,

please help us to help you and provide answers to the following questions.

What is the problem you are having with rclone?

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

Which terminal are you running rclone from? Cmd? Powershell? Something else?

  1. you are using an old version of rclone, please update and test again.
  2. is that the entire script, just one line of code? if there is more code, please post.

I'm pretty sure I know the problem.

You are almost certainly accidentally clicking inside the command window.
By default in newer windows versions this will put the CMD window into "select" mode. This is actually kind of useful as it pauses allows you to copy out something you need or study what is happening - but for less experienced users it can also be confusing as it's not clear what is happening and CMD just appears to "hang".

When this happens it should say "select" in the title of the window, so now you can identify it. Pressing any button or right-mouse should resume the script. (you can still drag the scroll-bar with the mouse to keep the script paused if you need that).

If you are very annoyed by this and want to disable it from happening on accident, you can right-click on the title of the window and go to "properties" (if you want to disable it for only this window) or "defaults" (if you want to disable it for all future windows you open) - and remove the checkbox for "insert" in those options.

Does that solve it for you? :slight_smile:


I believe it does. lol.

1 Like

Actually this should be documented as a feature. Sometimes I have 4 4.5gb uploads in progress with no way to pause when I need temporary bandwidth. Now I can pause without restarting.

This is a feature of Windows CMD though, not rclone :slight_smile:

A way to control that via rclone though would be to enable the web-GUI (or just the RC in general). There you can set options while rclone is running - including setting a BW limit (temporarily or otherwise).

Also, rclone will just resume the upload if you cancel it and run it again. It will only lose progress on any files that were currently half-finished in transfer. All files that were already uploaded will just be quickly checked and skipped.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.