Rclone partially mount files and filter certain files to store local

What is the problem you are having with rclone?

I am new here and am using google drive as remote. I am using this with emby (ubuntu server). I have managed to mount google drive and able to see media files in library. emby scan all media files, generate and store metadata (nfo) files & movies poster in respective folders.

When server restart, mounted drive disappear, thus i have created cron job on boot which mounting drive after boot, not sure this is correct method or is there any other way without cron on boot.

I believe when drive mount, does not store files in local server, its contain only file infos like size, name etc. I am looking to archive few things as below and cant get my head around how to get there.

  1. when emby generate files, should upload to back to google drive
  2. after reboot, drives mounted and keep sync/copy of *.nfo and *.poster.jpg at server and not media files. by this way emby can read these files quicker.
  3. apart from nfo and jpg files should not stored at server and have from google drive on needed by emby in cache folder.
  4. do I have to use mount or sync command for above needs and if I have to use
  5. not sure should I use copy/sync in this scenario or also it can be combined with mount command and if yes than what will be my parameters.

when I run below command (google drive already mounted)

sudo rclone sync --interactive gdrive:Kids-Movies /opt/media/gdrive --filter "+ *poster.jpg" --filter "+ *.nfo" --filter "+ *fanart.jpg" --filter "+ *clearlogo.png" --dry-run

its asking for skip/overwrite.

I can use above command but not sure how can I make this automated on reboot and is this the right way or is there any other better way.

is there any way that we can use "rclone mount with filter where some files are loaded locally and rest are mount?

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-1037-azure (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads
--> YES

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

sudo rclone mount gdrive: /opt/media/gdrive  --umask=000 --vfs-cache-mode=writes  --allow-other --daemon

The rclone config contents with secrets removed.

type = drive
client_id = ###
client_secret = ###
scope = drive
root_folder_id = 
token = {"access_token":"###"}
team_drive = ###

A log from the command with the -vv flag

ANy help on this much appericiated.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.