Rclone OneDrive copying the same files each sync

What is the problem you are having with rclone?

I am syncing my OneDrive to an external drive and, each time the sync runs, it copies the same files:

Each time the task runs, there will be exactly the same number of files transferred, all with an output similar to the below (showing the sha1 hash then OK then Copied (replaced existing).

Any ideas as to what might be causing this? It's not a large number of files that re-download each time, but I am perplexed.


What is your rclone version (output from rclone version)

rclone v1.57.0

  • os/version: Microsoft Windows 10 Pro 2009 (64 bit)
  • os/kernel: 10.0.19043.1415 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync -P --no-update-modtime --log-file=C:\rclone\OneDriveLog.txt -vv OneDrive: OneDrive/

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":"REMOVED","expiry":"2021-12-18T12:36:17.5228255-05:00"}
drive_id = REMOVED
drive_type = personal

A log from the command with the -vv flag

2021/12/18 11:47:33 DEBUG : Pictures/High School/From SD Card/Family.jpg: sha1 = 7dbef82a137755b174a88c41175f2d1ffc981842 OK
2021/12/18 11:47:33 INFO  : Pictures/High School/From SD Card/Family.jpg: Copied (replaced existing)
Transferred:   	    6.567 MiB / 6.567 MiB, 100%, 39.290 KiB/s, ETA 0s
Checks:             34631 / 34631, 100%
Deleted:                5 (files), 0 (dirs)
Transferred:          113 / 113, 100%
Elapsed time:      2m27.6s

hello and welcome to the forum,

  • is there a specific reason to use --no-update-modtime.
  • if the same file is being copied each time, then rclone copy that single file and post the entire debug log.

I had tried using --no-update-modtime as debugging, just to see if it would fix the error.

I have since learned that this is likely the issue:

Adding --ignore-size seems to have fixed it.

Should probably have held off a few minutes before posting this. Thanks anyway!

i guess just another onedrive quirk.

OneDrive can be annoying. I have had weird bugs in addition to those noted on the docs.

Honestly, for a few directories that seem to do it the most (notably where the iOS app uploads photos), I have mored to --size-only. Size-based sync is less reliable as you can have false negatives (a modified file that doesn't change the size). However, this is pretty rare in practice and when it does happen to me, it tends to be benign. (e.g. some apps will add the last opened time to the file itself. I don't care if that isn't copied). FWIW, size-based is the default on many backends too.

When I am having time-based issues and I really need a perfect sync, I use --hash instead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.