Rclone on a vm, problemen?

I tried to use rclone on multiple linux distro's
Running linux as a vm (virtual machine, kvm qemu)

I used multiple versions of rclone, first distro version than latest rclone version.

All VMs (mint, fedora, popos, manjaro) were fresh installs, first thing is install rclone to mount OneDrive (Microsoft) straight forward personal account.

All goes well until I try to mount OneDrive. It sees the drive sometimes labeled 0, sometimes 1. But it won't mount, no error, just goes back to the latest menu option that I just answered.

Hours of trying no result. What am I doing wrong?

hello and welcome to the forum,

rclone will run great on a vm, many of us do that.
make sure you have enough memory and disk space.

if you let us know what you plan to do with the vm, then we can offer good advice on the specs for that vm.
running a media server such as plex or what?

1 Like

I gave the machine 8 cpu's, 8 GBs of memory, and 50 GBs of HDD.

I am testing in vm for buying a laptop later.

Just a regular Office laptop, nothing special. Wish to run Linux Mint and LibreOffice.

Encrypted drive would be awesome.

ok, i see that you re-edited your first post.

make sure to use latest stable v1.61.1

when you first posted, there was a template of questions to be answered.
help us to help you and answer all the questions.

Because I tried multiple VMs, Multiple Distro's, and multiple versions of rclone with sometimes different outcome I found it very difficult to use the template. Sorry for that.

that is most likely the problem, so just use that latest version on all machines.
might be able to run rclone selfupdate
and if that does not work, then https://rclone.org/downloads/#script-download-and-install

the rclone config file is portable. create and test it once on one machine and copy it to other machines.

so using latest rclone and one well tested config, we are much closer to a solution

Thank you so much. Tomorrow I will try again with a Linux Mint VM. I will give it 8 cpu's, 8 GB memory and 200 GB of hdd (just to be sure), and I will install the latest stable version of rclone.

Any suggestions on multiple users with the same OneDrive using the VM, later laptop ?

Any suggestions on encryption for the mounted OneDrive ?

Thank you!!!

i run rclone mount on a portable router
--- 128MiB memory
--- no hard drive

so the actual linux os, the specs of the vm really do not matter for now.

sure, but please, let's keep this simple,
--- just pick a vm, and let's use only that vm. the vm is not the problem.
--- install latest rclone
--- create a remote for onedrive, let's call it onedrive:
--- test remote using rclone ls onedrive:
only after that, can we try rclone mount and answer your other questions :wink:

The Installation went well.

Now find out how to mount the OneDrive to /home/myname/onedrive
Hmm I don't know what CLI to use?!?

So I use the Web GUI instead.
That worked using the webgui rclone rcd --rc-web-gui.
That is great, I can see my files and directories.

Few more questions:

  1. What CLI did I just do, for next time?
  2. Will this survive a reboot?
  3. Can I use my config for the laptop installation?

good

another gui is https://kapitainsky.github.io/RcloneBrowser/

  1. not sure, how did you configure the webgui?
    might try rclone mount onedrive: /home/myname/onedrive
  2. no. can use cron or systemd.
  3. yes, use rclone config file to find the rclone.conf and copy that to the laptop
  1. I get a message: 2023/01/18 15:05:43 NOTICE: OneDrive root '': --vfs-cache-mode writes or full is recommended for this remote as it can't stream , yet it seems to mount fine, ignore or modify? Check screenshots to see what I did in the GUI, really straightforward, did not change anything else.


    3
  2. Thank you, will do.
  3. Oh thats great!
  1. for rclone mount to emulate a local file system, sometimes need to use the rclone vfs file cache.
    this is required for LibreOffice to edit files.
    so using the webgui, for CacheMode, change off to writes
    "Cloud storage objects have lots of properties which aren't like disk files - you can't extend them or write to the middle of them, so the VFS layer has to deal with that."

  2. for systemd service file, check out https://github.com/animosity22/homescripts/blob/master/systemd/rclone-movies.service
    tho that is for dropbox, the overall service file format is a good starting point.

  3. yes it is great!

OMG I almost gave up yesterday, so glad I put in this post and got all your answers. Thank you so much!!!

I am going to use your rclone mount onedrive: /home/myname/onedrive in combination with crontab. And like this I will have no problems with LibreOfiice files right?

need to add the vfs cache mode
rclone mount onedrive: /home/myname/onedrive --vfs-cache-mode=writes