Rclone + NSSM no progress bar

What is the problem you are having with rclone?

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: Microsoft Windows 10 Pro 22H2 (64 bit)
  • os/kernel: 10.0.19045.4170 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I'm using rclone with NSSM with following arguements "mount Uploads: R: --config "C:\Users\XXXXXX\AppData\Roaming\rclone\rclone.conf" --vfs-cache-mode full" and when copying or dragging and dropping a file into the Google Drive mounted folder in Windows Explorer I don't get the progress bar. Before I added --vfs-cache-mode full onto the arguements it would show but without that I would get and error that said "The file 'xxxxxx' is too large for the destination file system."

Does anyone know how I can get the transfer progress back?

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

rclone v1.65.2
- os/version: Microsoft Windows 10 Pro 22H2 (64 bit)
- os/kernel: 10.0.19045.4046 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.21.6
- go/linking: static
- go/tags: cmount

C:\Users\XXXXXX\Downloads\RClone>rclone config redacted
[Uploads]
type = drive
scope = drive
token = XXX
team_drive =
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

There isn't any log to post as I'm using NSSM.

Updated to the latest version of Rclone and still the same.

The progress bar I'm referring to is the following - https://howtomanagedevices.com/wp-content/uploads/2021/02/image-58.png (this is a random image from Google I found)

When using vfs cache (uploaded) files are cached locally and it is the reason why you are not seeing progress bar. can you try with or without --network-mode. Alternative use rclone copy instead of rclone mount for uploading. Please see docs for more info Documentation

Oh OK, I have occasionally been using rclone copy to transfer the files but sometimes it doubles up, for example if the file size is 600mb, it ends up transferring 1200mb.

Also, with --network-mode would that help stop the error I was receiving before I added vfs cache where it would fail and say The file 'xxxxxx' is too large for the destination file system.

Sounds like you are having a bad/unstable internet connection and rclone is retrying uploads. Since continuation of broken uploads is not possible and retries are also not possible when not using rclone copy nor vfs cache it fails with " The file 'xxxxxx' is too large for the destination file system". If possible use rclone copy with retries or get a better connection.

PS. can add -vv to your command to see whats actually happening.

Edit: need to use --log-file /path/to/logfile as you are using NSSM. read the logfile with a text editor after running rclone with NSSM

I think it probably is my connection. I am on WiFi as I don't have a wired socket near my computer and my upload speed max is about 10mbit/s.

not sure that would matter, as the command uses the vfs file cache?

please post a debug log so we can look at it, or at least, with the top 20 lines and the lines with the full error message.

Sometimes it works fine without the error message and then sometimes the error message shows. I have been doing a test and finally got it to show the error.

nssm_log.txt (99.6 KB)

Truncate: Can't change size without --vfs-cache-mode >= writes
WriteFileHandle.Write: can't seek in file without --vfs-cache-mode >= writes

need to use --vfs-cache-mode=writes or --vfs-cache-mode=full

tho, hard to know what is going on without the top 20 lines of the debug log

Yeah this was with --vfs-cache-mode=full remove from the arguements so I could show the log when it happens. I just don't like that I can't see when it has completed or how much time is left when that is added.

I will probably just run rclone copy manually instead of uploading it with NSSM.

Also, this is the full log, there were no other lines.

maybe, with a bit of scripting using --rc-enable-metrics
i do not use the rc interface, so i can help you with that, maybe someone else knows?

if it were important to me, i would kludge it
--- create a second rclone mount only for uploads with --vfs-cache-max-age=1m
---as a rough indicator of progress, monitor the size of the cache folder.
when the folder is empty, uploads have completed

I think i will just run the script manually rather than doing other things.

Thanks for the help, good to know it's not just me doing something wrong.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.