Rclone not uploading to gdrive


Yesterday I started trying to set up Rclone. But unfrotunately I need a little help.

When I typ ls /media/dmk/skyline/gdrive in, then the file is empty. While it should look like my google drive folders.

I have done the following things sofar:

In rclone config:

For the drive

For the cache

In the .conscript.sh

I made the cronscript executable.

in crontab -e

I know that those two don't link to eachother yet (cronscript). But otherwise rclone is moving the files to the folder /media/dmk/skyline/gdrive. Unfortunately this is not linked with gdrive. Here you can see that it's empty while my gdrive has folder and files:

Does someone know what went wrong?

Did you also mount rclone?
If yes, what does the command look like?

Yep missing the mount :slight_smile:

Oh didnt include it yet.

The mount is

Line 5 of .conscript.sh is missing a colon after Gdrive. It should look like this
/media/dmk/skyline/bin/rclone copyto /media/dmk/skyline/deluge/completed Gdrive: -v --min-age 1

You're probably getting errors without the colon. In the future, you can check your output for stuff like that by appending >> rcloneoutput.log to the end of the command, or using another variation for logging.

Thanks! I immediately changed it.

Unfortunately I still can't see any folders with the command:

I just noticed I got 2 folders:

However they are both empy.

Is your mount running?
You can check by running ps aux | grep rclone

I get the following output:

I have no idea what it says :frowning:

You don't have anything mounted.

Start your mount, then see if the files are there.

Also note, in linux gdrive/ and Gdrive/ are different folders. Your current mount command is pointing to the lowercase version; gdrive.

Try /media/dmk/skyline/bin/rclone mount -vv --read-only --allow-other --gid 33 --umask 0027 --dir-cache-time 300h --daemon Gdrive: /media/dmk/skyline/gdrive >> ~/rclonemout.log
then ls that directory.
If that doesn't work, you can read the contents of ~/rclonemount.log and find out what is going wrong.

Also, instead of running it in daemon mode, you might use tmux. I prefer that quite a bit more than anything else. If you try tmux, I can give you some helpful hints that I use with my setup.

I entered the command and got this:

I don't think anything is going wrong?

The log is empty

And the gdrive folder is also still empty

Check to see if your mount is still running.
ps aux | grep rclone

You can also check to see what is in there.
rclone lsf Gdrive: --fast-list

Its still not running :frowning:

With the last command you can see the folders!

Try a simple mount, see what you get.
rclone mount Gdrive: /media/dmk/skyline/gdrive --vfs-cache-mode full
ls /media/dmk/skyline/gdrive

Also, I just noticed that you are passing cache flags to your drive remote, not your cache remote. I suspect that's the ultimate issue.

If the above works, then try your original mount but swap out Gdrive: for Gcache:
Also, try it without the --daemon flag.

The first command is not working

I thought let's give the Gcache a try.

What operating system are you using as it seems you don't have fuse installed?

I don't think so.
I'm on a seedbox - Feralhosting

Hmm, this is odd as they say they can't install fuse but they give instructions for rclone.


I'm not sure how to make rclone work without fuse as the mount requires fuse to be there.

Yeah, feralhosting doesn't support fuse mounts.

Do you actually need the mount or you just need to transfer the files to GDrive? The copy or move don't require the fuse package to be installed.

1 Like

Thanks copy works perfect.
I kinda wanna run plex aswell, but guess i have to find a cheap vps for this.

fwiw, running plex on feral is not a great idea as they are shared boxes. They have found some way using namespaces (I think) to run multiple plex servers on a single box.

So yep a separate vps is the way to go.