Rclone not seeing shortcuts from other users drives

Shortcuts that point to files on other peoples Google Drives are not showing with the latest ARM beta. Previously (before Google implemented shortcuts) I could add a shared file and Rclone would see it and I could download it. Now, only locally created shortcuts are shown by Rclone. Is this expected behaviour?

Version - rclone v1.51.0-259-gc2e0b827-fix-4098-drive-shortcuts-beta

The command used was the simple ls (list objects), and it only showed the one local shortcut I created, and the one local file that was in the directory. It doesn't show shortcuts that point to files on other users Google Drives.

In the past, I used to select "Add to my drive", and a copy of the file was shown in the directory of choice, which I could then download with rclone.

Now the only option is to "Add shortcut to Drive", and rclone doesn't show them.

Verbose log:

[root@PersonalCloud Downloads]# rclone ls Google:Cheese -vv
2020/05/14 19:30:12 DEBUG : rclone: Version "v1.51.0-259-gc2e0b827-fix-4098-drive-shortcuts-beta" starting with parameters ["rclone" "ls" "Google:Cheese" "-vv"]
Enter configuration password:
2020/05/14 19:30:17 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
14194 Menu Options.docx
17734 eula.1028.txt
2020/05/14 19:30:20 DEBUG : 6 go routines active
[root@PersonalCloud Downloads]#

I am still able to download the file however.

I used the command

rclone copy "Google-Cheese/-Downloadgameps3.com] B450VC.part02.rar" -shares-Public-Downloads- --progress

(I've had to change slashes to dashes as the forums thinks I'm trying to post a link and it says link posting not allowed).

and it works. I just can't see the shortcut filename in rclone.

Thanks for any help guys.

I tried this and it worked for me.

Can you try again with the latest beta - there are some more changes to the shortcut code from that version.


If that doesn't work, can you describe how you made the shortcut?

Note that the destination files need to be shared with you (or readable by you) in order for the shortcut to work.

Yes, I can confirm that this issue is fixed in v1.51.0-323-g4a1b644b-beta.

Apologies, I thought I was running the latest beta.

Thank you for all your work with this very handy software.

1 Like

Great news!

No worries - I can't remember the thing that fixed it now either!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.