Rclone not respecting poll interval

  1. The full command you’re attempting to use.

rclone cmount crypt: /Users/user/Media --vfs-cache-mode full --vfs-read-chunk-size 32M --vfs-cache-max-size 100G --dir-cache-time 5000h --poll-interval 1m --allow-other -vvv --log-file=rclone.log

I'm trying to get the mount refreshed. It does not respect the poll interval, sometimes it doesn't get refreshed to hours. Seems like without the VFS cache it works for a little bit longer, but in the end seems to get the same results.

For example, I create a folder via a separate server, but I do not see the folder on the macOS mount until I restart the mount.

  1. A logfile of rclone’s output with personal information removed. If it is large, you can use services like pastebin.com . It’s usually helpful to increase the logging with -v or -vv depending.–log-file=FILE
  1. The rclone config you’re using. If you don’t know where to find it, check here. Before posting ensure you’ve removed any confidential information like credentials.https://rclone.org/commands/rclone_config_file/
[dropbox]
type = dropbox
client_id = <redacted>
client_secret = <redacted>
impersonate = <redacted>
token = {"access_token":"<redacted>","token_type":"bearer","refresh_token":"<redacted<","expiry":"2022-05-30T00:11:58.832297+02:00"}

[crypt]
type = crypt
remote = dropbox:encrypted
password = <redacted>
password2 = <redacted>
  1. What version of rclone you’re using. It’s also helpful to try rclone with the latest beta if you’re using a stable release to understand if your issue was recently fixed.
    1.58.1 on macOS

Can you log an issue on github?

To replicate, a smaller command to show the same thing.

felix@gemini:~$ rclone mount DB: /home/felix/test --poll-interval 10s -vvv
2022/05/29 16:03:59 DEBUG : Setting --config "/opt/rclone/rclone.conf" from environment variable RCLONE_CONFIG="/opt/rclone/rclone.conf"
2022/05/29 16:03:59 DEBUG : rclone: Version "v1.58.1" starting with parameters ["rclone" "mount" "DB:" "/home/felix/test" "--poll-interval" "10s" "-vvv"]
2022/05/29 16:03:59 DEBUG : Creating backend with remote "DB:"
2022/05/29 16:03:59 DEBUG : Using config file from "/opt/rclone/rclone.conf"
2022/05/29 16:03:59 DEBUG : Dropbox root '': Mounting on "/home/felix/test"
2022/05/29 16:03:59 DEBUG : : Root:
2022/05/29 16:03:59 DEBUG : : >Root: node=/, err=<nil>
2022/05/29 16:04:09 DEBUG : Dropbox root '': Checking for changes on remote
^C2022/05/29 16:05:10 INFO  : Signal received: interrupt
2022/05/29 16:05:10 INFO  : Dropbox root '': Commiting uploads - please wait...
2022/05/29 16:05:10 ERROR : /home/felix/test: Unmounted rclone mount
2022/05/29 16:05:10 INFO  : Exiting...

Seems to be dropbox only btw as I went back a myriad of versions and can't see where it broke offhand.

Google Drive works fine:

felix@gemini:~/rclone-v1.55.1-linux-amd64$ cd
felix@gemini:~$ rclone mount GD: /home/felix/test --poll-interval 10s -vvv
2022/05/29 16:09:59 DEBUG : Setting --config "/opt/rclone/rclone.conf" from environment variable RCLONE_CONFIG="/opt/rclone/rclone.conf"
2022/05/29 16:09:59 DEBUG : rclone: Version "v1.58.1" starting with parameters ["rclone" "mount" "GD:" "/home/felix/test" "--poll-interval" "10s" "-vvv"]
2022/05/29 16:09:59 DEBUG : Creating backend with remote "GD:"
2022/05/29 16:09:59 DEBUG : Using config file from "/opt/rclone/rclone.conf"
2022/05/29 16:09:59 DEBUG : GD: Loaded invalid token from config file - ignoring
2022/05/29 16:09:59 DEBUG : Saving config "token" in section "GD" of the config file
2022/05/29 16:09:59 DEBUG : GD: Saved new token in config file
2022/05/29 16:10:00 DEBUG : Google drive root '': 'root_folder_id = 0AGoj85v3xeadUk9PVA' - save this in the config to speed up startup
2022/05/29 16:10:00 DEBUG : Google drive root '': Mounting on "/home/felix/test"
2022/05/29 16:10:00 DEBUG : : Root:
2022/05/29 16:10:00 DEBUG : : >Root: node=/, err=<nil>
2022/05/29 16:10:10 DEBUG : Google drive root '': Checking for changes on remote
2022/05/29 16:10:20 DEBUG : Google drive root '': Checking for changes on remote
2022/05/29 16:10:30 DEBUG : Google drive root '': Checking for changes on remote

Will log an issue on Github.

I think there are two issues here; one with the poll interval, another one when mounting without a backslash, e.g. dropbox:. This will, at least on macOS, cause it to not update the cache. When I mount with dropbox:/ it works correctly.

Grand.

Are you using dropbox for business? Using a leading / does different things in that case. See the docs.

It might be that there is a bug in the poll interval code to do with this though. If you can make a nice demostration of the difference, then please make another issue about this.