Rclone mounts break SFTP clients to move files inside/outside the mount

Just try yourself.

Connect to your box with a sftp client for Windows like WinSCP or Filezila Client create a file outside the mount folder, then try to move it to inside, you’ll fail.

I think this is really annoying and makes working with a mount folder locally difficult. I’ve found that the mv command works.

What errors does the mount give? Have you tried the latest beta?

I deleted the logs, but just try yourself and you’ll know.

It’s really annoying

Can you give a sequence of commands to replicate please? I’m having trouble following your description.



Just mount a rclone with google drive, connect to it with WinSCP, try to move files using drag and drop to and outside a folder inside the mount. It will fail with error 4.

I’m having the same issues, works when moved or renamed locally, or via a samba share. Just doesn’t work when using sftp clients (I’ve tried two and the same issues exist in both).

Same error over here!

Might it be a specific problem with WinSCP?

I’m on on a mac and it does this on transit and cyber duck.

The issue I see to replicate is mount google drive and then try to view the folders via an soft-pedalled client.

I can rename folders but not files. Works natively or via a samba share.

I need to see the logs from rclone mount with -vv of the problem. Also did you try the latest beta?