Rclone mounted drive - apps cannot see sub-folders and files

Hello Dear Team,

What is the problem you are having with rclone?

The main folders are visible in apps, but sub-folders and files not. Looks like a permission problem.

What is your rclone version (output from rclone version)

rclone v1.36

Which cloud storage system are you using? (eg Google Drive)

Google Drive (drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone mount --allow-other --umask 0000 --uid 0 --gid 0 remote: /data

I tried with PID and GID of root, app runner user, my simple user.
Umask I tried 0000 and 000.

The rclone config contents with secrets removed.

n/s/q> n         # New
name>remote      # Name of my connection
Storage>drive         # Google Drive storage type
client_id> xxxx      # My Personal Client_ID
client_secret> xxxx  # My Personal Secret
y/n>y             # Auto config, yes

Pleas try to give me the hint how should I handle this.

Thank you very much,
Best regards,

Your version is older than most dinosaurs.

Please upgrade.

Hello, The server is ubuntu 18.04, that is the version what apt-get install gets me, there is no way to update this server.

Don't use the repos.


There isn't anyone that's troubleshooting that version.

1 Like

Updated to v1.57.0


Add -vv --log-file /tmp/rclone.log to your command.

Share the full debug log file when done.

Working perfectly. Thanks for the hint, I didnt thought a simple update will solve it. Perfect solution. Have a nice day.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.