Rclone mounted but Plex can't see it

Hello all!

I'm trying to set up Rclone from my seedbox and it's kinda difficult.

I have succesfully setup a drive to google drive and it's uploading automatically using crontab. However Plex isn't reading those files correctly and I dont have access to all my folders in Google drive. It's basically just the name that I called it when I setup the drive in rclone, but no folders inside.

Is it correctly mounted?
And why can't plex see the content and any subfolders inside the google drive?

What's your mount command? What version of rclone are you using?

I'm using version 1.48.0

And I don't have a mount command. I dont have access to the root. Is this necessary?

I'm not following how you are setup. You don't need root for rclone as you just need fuse installed.

How is Plex accessing the files if you do not have a rclone mount?

I did the rclone config part (this page https://rclone.org/drive/ only first code) so it's in the file explorer. The problem is that I can't see all the subfolders in it and plex can't see any of the content (those are in the subfolders).

I haven't used any mount command and when i try to use it I get the following error: "Mount: Only root can do that."

Can you share what command you are running specifically and the error?

[felix@gemini ~]$ id
uid=1000(felix) gid=1000(felix) groups=1000(felix),971(docker)
[felix@gemini ~]$ rclone mount gcrypt: /Test

Example mount of a non root user.

Yh sure! I have the following things set up.

All words that are in italics have been changed.

The cache

The drive

Nano cronscript

Crontab -e

This is everything I have set up. The crontab is working fine and is uploading everything to google drive. Here I'm manually replacing the files to the correct folders.

The problem is as follows:
There are no subfolders I can choose from (I place all the content to those folders) and I don't get any media when I select this. So I thought something went wrong with Rclone?

You need to mount a drive on rclone to see it as you have uploaded but without a mount on your local machine, you can't see it.

I tried this command line, but it didn't work.

Do you happen to know what I'm doing wrong or should do instead?

You need a spot to mount it to so at the end of the command, you need to specify a folder to mount.

You only included a piece of the systemd so it's hard to tell if you are running as a user or as root.

What does:

/home14/skyline/rclone version


Rclone version shows me:

and /home14/skyline/rclone version shows me:

By the way thanks a lot for your help trying to figure this out! :slight_smile:

Can you share the whole .serivce file as that looks to be wrong as you are pointing to:

Which looks to be the wrong path for your rclone executable.

hmm, you are right. I shouldn't add /home14/skyline in front of it.

This is what I got. I should add somewhere another path I think?

You need something to mount it to at the end of your command so you need to make a directory so it can mount to that.

Great! This command is working perfectly!

One more question:
I did use the command yesterday. Plex was seeing the subfolders in gdrive perfectly. However when I tried to watch a movie right now it's gone. I can't see any subfolders anymore and I'm back to the start.

Should I make a crontab code of this so it repeats the command line?

You need to keep the command running to always see the files.

Your best bet would be a service for that but that isn't possible without root.

The other alternative is to start a tmux or screen session, run the command within it and then detach from it.

I have no idea how to make a screen session or tmux, but wouldn't a cronscript work?

I kinda made one and it's mounted. It checks every 2 minutes if it mounted.
I have no idea if it will be unmounted once in a while untill the 2 minutes are over. But if you guys tell me that a tmux or screen session would be better then the cronscript then I will look into that!

You can just append "--daemon" at the end of your command and that will run the command in the background so if you log out, it won't exit.

Thanks! Got the following code:

Its working :slight_smile:

I'd remove allow-non-emtpy as that's just a bad parameter and allows for overmounting/hiding things.

Any reason you are setting a poll interval rather than just using the default? I'd remove that.