Rclone Mounted but Now showing in Plex Media Manager

What is the problem you are having with rclone?

I'm Trying to setup a Plex server using Linuxserver/Plex docker. Managed to setup plex server and all. and I'm able to mount http remote in my server. but its not showing in Plex Media Manager. One time it worked, when i try to do the same it didn't work, i dont remember what i did. sharing more information below, including the commands i tried

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.1

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-1049-oracle (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

I'm using an HTTP Remote system.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount indox2: /mnt/gcloud/ -vv --allow-non-empty

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
scope = drive
token = XXX
root_folder_id = XXX
shared_with_me = true
team_drive =

type = http
url = https://odd-bird-1319.zwuhygoaqe.workers.dev/

type = http
url = https://edytjedhgmdhm.abfhaqrhbnf.workers.dev/

A log from the command that you were trying to run with the -vv flag

root@plox:~# rclone mount indox2: /mnt/gcloud/ -vv --allow-non-empty
2024/01/15 14:32:15 DEBUG : rclone: Version "v1.65.1" starting with parameters ["rclone" "mount" "indox2:" "/mnt/gcloud/" "-vv" "--allow-non-empty"]
2024/01/15 14:32:15 DEBUG : Creating backend with remote "indox2:"
2024/01/15 14:32:15 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2024/01/15 14:32:15 DEBUG : Root: https://edytjedhgmdhm.abfhaqrhbnf.workers.dev/
2024/01/15 14:32:15 INFO  : https://edytjedhgmdhm.abfhaqrhbnf.workers.dev/: poll-interval is not supported by this remote
2024/01/15 14:32:15 DEBUG : https://edytjedhgmdhm.abfhaqrhbnf.workers.dev/: Mounting on "/mnt/gcloud/"
2024/01/15 14:32:15 DEBUG : : Root:
2024/01/15 14:32:15 DEBUG : : >Root: node=/, err=<nil>

linuxserver/plex - Docker compose

    image: lscr.io/linuxserver/plex:latest
    container_name: plex
    network_mode: bridge
      - PUID=1001
      - PGID=1001
      - TZ=Etc/UTC
      - VERSION=docker
      - PLEX_CLAIM= claim-BebNd8rpKVYsz
      - /mnt/plex:/config
      - /mnt/gcloud:/media
      - "32400:32400"
      - "1900:1900/udp"
      - "5353:5353/udp"
      - "8324:8324"
      - "32410:32410/udp"
      - "32412:32412/udp"
      - "32413:32413/udp"
      - "32414:32414/udp"
      - "32469:32469"
    restart: unless-stopped

Here i used portainer to deploy docker compose

You probably need to add --allow-other on your mount command.

Yeah that worked. and i need to restart my container too.
do you recommend any other flags to improve this? New to Rclone.

No, thats a docker thing. if you mount a storage-path after docker mount the path into a container, docker didn't refresh the path after the initial mount into the container.


yep thats true.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.