Rclone mount with windows and plex bug

my plex wont stop scanning it’s completed but still scanning in infinite loop, i have to automatically choose cancel scan to stop it , even if i add one or 2 new movies it will scan forever , anyone have idea?

You have to let it finish completely as it is needs to analyze all the files as well.

Why do you think it is in an infinite loop?

oh deff infinite loop, i set it to scan all my sections last night ( 6 hours ) and it stayed on the first one , all movie metadata was there and complete , it never went to the others, all movies were scanned successfully.
so i tested it this morning adding 1 movie to the same section and it took 5 seconds to find the metadata but it kept spinning and searching for an hour until i stopped it.

How much data are you scanning? If you just added it, it has to analyze and that doesn’t look like movement so you’d have to check the logs to see what it is going on.

I’m sure it looks like it is doing nothing, but it most definitely is analyzing media.

862 for that one , and i can see all of them everyone of them is added, it might be analyzing but i didnt think it could take that long. Im trying another section now with just 100 ish movies , ill see how long it takes.

i haven’t figured how to get logs yet for windows while using the Service to mount gdrive , im still working on it.

I scanned about ~40TB in 2 1/2 days of constant scanning. I have:

Media items in Libraries
Library = Movies
  Items = 1993

Library = TV Shows
  Items = 20548

at this time and a gigabit link and my own API key and a very tuned setup.

well the scan did stop, but with

2018/12/03 16:02:01 ERROR : IO error: open file failed: googleapi: Error 403: The download quota for this file has been exceeded., downloadQuotaExceeded

now that i got my log file working ill try to figure out why im getting banned so quick when im using my own api key

What’s the output if you type “rclone version”

felix@gemini:~$ rclone version
rclone v1.45
- os/arch: linux/amd64
- go version: go1.11.2

rclone v1.45

  • os/arch: windows/amd64
  • go version: go1.11

i got that error 2018/12/03 16:02:01 ERROR : IO error: open file failed: googleapi: Error 403: The download quota for this file has been exceeded., downloadQuotaExceeded

but i wasent banned, all i did was unmounted and remounted now all my sections are all finished and everything is working properly.

I noticed that my RCLONE.LOG contains only this
2018/12/03 18:34:41 DEBUG : rclone: Version “v1.45” starting with parameters [“rclone.exe” “–log-level” “DEBUG” “–log-file” “C:\rclone2\RCLONE.LOG”]

even after doing all my scans there is nothing in the log, is the log only when there are errors?

Are you sharing with anyone else? Have rclone running anywhere else? That message shouldn’t happen on 1.45.

What’s your mount command?

in Nssm i added these

Application tab:
Path: C:\rclone\rclone.exe
Startup Directory: C:\rclone
Arguments: mount gdrive-crypt: q: --config “C:\rclone\rclone.conf”
Service name: Rclone Mount

it auto starts as a service , i have no mount commands just mount , then yesterday i opened up a cmd and did

cd C:/rclone2 ( it’s my rclone folder )
then i did rclone.exe “–log-level” “DEBUG” “–log-file” “C:\rclone2\RCLONE.LOG”
that created a log file …nothing in the log tough .

and it’s not shared with anyone.

I got the ban error but was never actually banned i did have to Stop my rclone service and Restart it yesterday " same thing as unmounted and remounted it." all works good since then

You’d have to put the log file parameters as part of arguments that you have above as it needs to be part of your mount.

ok ill look into that as soon i get a chance

i added that command in nssm for auto start as service with log and it’s working perfectly.

THANKS :slight_smile:

are these settings good for the rclone mount

I took RUN a partial scan when changes are detected off

No, deep analysis is very intensive as it runs through each file completely and probably the cause of your ‘forever’ scans.

The time each scan is scheduled doesn’t matter much.

I run with:


so should i take off
upgrade media analysis during maintenance.
preform extensive media analysis during maintenance
preform refresh of program guide data

not sure exactly where the exact setting is witch i think is preform extensive media analysis during maintenance
as long each file i add is analyzed , so i just want to make sure .
if i take off preform extensive media analysis during maintenance and add media and scan it normally using manual scan library or the periodically , does it analyze the file? let me see your scheduled task settings

I shared my settings and you can see what I have on. I personally choose to keep that on as my library is analyzed and if they do want to rescan some stuff, I’m ok with that.

Extensive Media Analysis is only used for bandwidth controls, which I do not use so I have no need for that as that goes through the file 100% to figure out bitrates on the file.


Regular media analysis, it is just checking the mediainfo for the file so it can assess the video/audio codecs/etc. That happens regardless of if you do it or not as if you click play, it has to analyze the media before it plays it. Normally that happens when it it scanned in.