"rclone mount" with "--rc" does not using the new config values after "rclone rc config/update" get executed

What is the problem you are having with rclone?

"rclone mount" with "--rc" does not using the new config values after "rclone rc config/update" get executed

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 7, 64 bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --rc
rclone rc config/update --json "{\"parameters\": {\"upload_cutoff\": \"10M\", \"chunk_size\": \"5M\", \"upload_concurrency\": 3}}"

The file rclone.conf updated correctly.
When I query the new config with command:

rclone rc config/get

The result shows it correctly updated too.
But when I test it with a new file uploading, the old values is used for the new transfer (by observing the DEBUG log, the old chunk_size is 6M (being using), the new value is 5M).

By the way, when I use options/set, it works on the fly.
After command like below get executed, the new file downloading properly using the new value (MultiThreadStreams).

rclone.exe rc options/set --json "{\"main\": {\"MultiThreadCutoff\": 10485760, \"MultiThreadStreams\": 2}}"

Is this an expected behavior for updating the config with the "rc" command?
Maybe "rclone config" has been cached somewhere, and a restart is needed for picking up the updated config values? Or, only transferring related config properties not been honored on the fly?

And, I cannot find options to update the cache dir with "rc" command, can we update the cache dir when using rclone mount with "--rc" option on the fly?

that is a very old version of rclone, latest stable is v1.55.1

What happened is that the backend is cached, so the config isn't applied until a new backend is made.

You can flush the backend cache with Remote Control / API however I think newer versions of rclone will do that for you automatically.

I tried v1.55.1, the result is the same as v1.52.3

I tried v1.55.1, and "rc fscache/clear" get invoked successfully, but seems the new transfer does not use the new chunk_size (which updated via "rc config/update").

What kind of situation would be considered as a "new backend"? I started a "rclone mount" with an existing config (remote), then trying to update the config via "rclone rc config/update", the name of the remote does not change, will config/update then fscache/clear make current mount read the updated config values? (the rclone.conf updated correctly after config/update executed.)

Ah, if you are using an rclone mount you will need to unmount it to release the backend, clear the cache, then remount it again.

In general backend parameters (such as chunk size) are only read when the backend starts up.

Thanks for this clarification.
It's clear now, when using rclone mount, a remount is needed for utilizing the new config/backend parameters.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.