Rclone mount upload speed capped at 15mbps

So I’ve noticed that when uploading to my Google Drive mount it always caps out at 15mbps (regardless of the machine or connection im running it on). Am I missing something in my startup command that would help it achieve higher speeds?

this is the command im using: rclone mount -v gdrive:Videos ~/rdrive

Sorry for asking if the answer is stupidly obvious, but I cant figure it out.


Are you transferring lots of small files? If so increase --transfers

How are you measuring the speed? Rclone measures speed in MByte/s normally.

Hello, thanks for your reply!!

The files im trying to transfer are single big files (10-20GB). Am I outta luck?

You could try increasing --buffer-size which will increase read-ahead. This may make a difference… Otherwise I’m not sure…

Sorry to resurrect this old thread I made. I gave up and left it at the default settings, but felt inspired to do better on it

Changing the --buffer-size didn’t help, but --vfs-cache-mode full helped. up to 24~30MiB/s now

Any other ideas on what could help improve this? I know mount is not meant for uploading and will never be as good as COPY, but still trying to get it as good as I can, as Its essential to my workflow for sonarr.

Just start a new thread if you have questions as it’s a 2 year old thread.