Rclone mount results in BSOD (SYSTEM_SERVICE_EXCEPTION)

What is the problem you are having with rclone?

Using rclone mount to mount an Educational account's Google Drive, and accessing a file or folder's Properties page results in a BSOD, stop code SYSTEM_SERVICE_EXCEPTION

What is your rclone version (output from rclone version)

rclone v1.51.0

  • os/arch: windows/amd64
  • go version: go1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10, 64bit, version 1909

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount GDrive-Edu:/ Z: --vfs-read-chunk-size 128M --dir-cache-time 5m0s --fuse-flag --VolumePrefix="\gdrive-edu\GDrive Edu"

The rclone config contents with secrets removed.

type = drive
client_id = REDACTED
client_secret = REDACTED
scope = drive
token = {"access_token":"REDACTED","token_type":"Bearer","refresh_token":"REDACTED","expiry":"2020-05-27T15:09:34.5122744+01:00"}
root_folder_id = REDACTED

type = drive
client_id = REDACTED.apps.googleusercontent.com
client_secret = REDACTED
scope = drive
token = {"access_token":"REDACTED","expiry":"2020-05-25T23:53:48.6377749+01:00"}

type = onedrive
drive_type = personal
token = {"access_token":"REDACTED","expiry":"2020-05-27T14:17:02.5018959+01:00"}
drive_id = REDACTED

A log from the command with the -vv flag

The log file never appears, I assume it crashes before it gets a chance to write to the disk.

I was using Drive File Stream before rclone until one day it just started BSODing every time. After that I tried giving rclone a shot, only to find it BSODing aswell (same error as Drive File Stream, "SYSTEM_SERVICE_EXCEPTION")
I have minidumps from the crashes but I don't know what to do with them.
Using WinFsp 2020.1 B2
PS: I don't have Avast installed, only Windows Defender.

PSS: I'm currently using RaiDrive to access my Google Drives and OneDrive, which although a bit slow, doesn't crash. Also in my rclone mount command I'm mounting as a network drive because I thought It'd fix it, but apparently not.

Thanks in advance.


the BSOD was happening before rclone, so this is not a rclone issue, correct?

after testing rclone but before using raidrive, did you uninstall drive file stream software?

v1.7B2 is pre-release beta software, perhaps use the lastest stable release.

for testing, i would simplify the rclone command as much as possible.
--dir-cache-time 5m0s, the default is 5m0s

rclone mount GDrive-Edu: Z:

there should be errors in the windows event viewer.
can you post the error from using file stream and the error from using rclone?

Thanks for the fast reply!

Yes, I uninstalled DFS (Drive file stream) before using rclone, I even tried reinstalling it once and ended up crashing again, so I uninstalled with Revo Uninstaller Pro to make sure it wasn't interfering with rclone.

I'm aware it's not directly a fault in rclone, but perhaps some resource both DFS and rclone make use of (but apparently not RaiDrive). I thought of posting on DFS's forums, but I thought I'd have more luck fixing my issue on the software that's open source.

I have a few relevant events around the time of the last BSOD (with rclone):

Critical Error:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331c3b3a-2005-44c2-ac5e-77220c37d6b4}" /> 
  <TimeCreated SystemTime="2020-05-27T13:10:33.668492700Z" /> 
  <Correlation /> 
  <Execution ProcessID="4" ThreadID="8" /> 
  <Security UserID="S-1-5-18" /> 
- <EventData>
  <Data Name="BugcheckCode">59</Data> 
  <Data Name="BugcheckParameter1">0xc0000005</Data> 
  <Data Name="BugcheckParameter2">0xfffff8053b6a35fa</Data> 
  <Data Name="BugcheckParameter3">0xffff9c83a07da610</Data> 
  <Data Name="BugcheckParameter4">0x0</Data> 
  <Data Name="SleepInProgress">0</Data> 
  <Data Name="PowerButtonTimestamp">0</Data> 
  <Data Name="BootAppStatus">0</Data> 
  <Data Name="Checkpoint">41</Data> 
  <Data Name="ConnectedStandbyInProgress">false</Data> 
  <Data Name="SystemSleepTransitionsToOn">4</Data> 
  <Data Name="CsEntryScenarioInstanceId">0</Data> 
  <Data Name="BugcheckInfoFromEFI">false</Data> 
  <Data Name="CheckpointStatus">0</Data> 

Error Event, 4 minutes after the Critical one:

[-](#) <Event xmlns=" **http://schemas.microsoft.com/win/2004/08/events/event** ">

[-](#) <System>

  <Provider Name=" **Microsoft-Windows-WER-SystemErrorReporting** " Guid=" **{ABCE23E7-DE45-4366-8631-84FA6C525952}** " EventSourceName=" **BugCheck** " />

  <EventID Qualifiers=" **16384** ">1001</EventID>






  <TimeCreated SystemTime=" **2020-05-27T13:13:54.376882600Z** " />


  <Correlation />

  <Execution ProcessID=" **0** " ThreadID=" **0** " />



  <Security />


[-](#) <EventData>

  <Data Name=" **param1** ">0x0000003b (0x00000000c0000005, 0xfffff8053b6a35fa, 0xffff9c83a07da610, 0x0000000000000000)</Data>

  <Data Name=" **param2** ">C:\Windows\MEMORY.DMP</Data>

  <Data Name=" **param3** ">00000000-0000-0000-0000-000000000000</Data>



The command you're referring me to, rclone mount GDrive-Edu: Z: , was my initial testing command,where I still got a BSOD.

After running the MEMORY.DMP through DebugDiag (not sure if this was the way to do it because I can't even find a proper reader for the .mht format the report comes in), I got this message:

 **MEMORY.DMP**  the instruction at  **nt!RtlValidSecurityDescriptor+0xa**  caused a kernel  **BugCheck 3B**  with the following details:

**BugCheck Code 0x3B**

Arg1 3221225477
Arg2 18446735282948158970
Arg3 18446658913913701680
Arg4 0

Edit: I tried changing to 1.7B2 to see if that fixed the issue, before that I was using the latest stable one. Both failed, obviously.

Just an update on this - I installed WinDbg and got a much better report when it analyzed the Memory dump from the latest BSOD.
Here's a link to it: https://pastebin.com/A3Wqf5pe

I'm not sure if I should continue pursuing this here or if I should move over to the guys at WinFsp, since the stack trace references it a lot.

Also, I figured out that accessing the security tab inside the Properties option triggers the BSOD every time, and also sometimes just triggers out of the blue when accessing something.

It's very unlikely rclone is causing bsod directly.

"I was using Drive File Stream before rclone until one day it just started BSODing every time"

it would seem to be an issue with your local computer.

  • check control panel - programs, sort by date and look for any new or updated software installed before the problem started.
  • check for recent windows updates.
  • perform system restore back to the day before the problem started happening.

edit: this is interesting, from that report
PROCESS_NAME: rclone.exe

i would try to use google file stream, generate the bsod and post the windbg report.
then we can compare.

Thanks for the input!

I know it's certain that rclone is not causing the bsod directly, but I don't know where else to go with this issue - Drive File Stream is a no-go since the forums there are a mess. I'll try my luck with the folks at WinFsp if this is too unrelated to rclone itself.

Also, checking recent software changes, windows updates or doing a system restore is out of the question- I've installed way to much software during these last months, Windows Updates A LOT, and I can't afford to lose all the things I've been tweaking recently to a system restore. Also, I sort of lost track of when this started happening.

I just forced a BSOD with DFS: https://pastebin.com/DxK6xLL7
There seem to be a lot of things in common with the Rclone BSOD report. Something about Valid Security Descriptors seems to fail? This seems to be it, since directly going to the Security tab of any file or folder instantly triggers a BSOD.

It'd be nice if rclone had a way to disable permissions on a mounted drive to see if this is the case, I've been searching for a while now but came to nothing

again, this seems to be with your computer config.
not rclone and not dfs

both bsod are the same

Arg1: 00000000c0000005
Arg2: fffff8013dca35fa

PROCESS_NAME: GoogleDriveFS.exe

i mentioned this, did you try to use the latest stable version.

"v1.7B2 is pre-release beta software, perhaps use the lastest stable release."

Yeah; initially I used the stable release. That didn't work, so I tried v1.7B2, which ended the same way.

I'll guess I'll try my luck over at WinFsp, thank you regardless!

Creating an issue on the winfsp GitHub is probably the way to go. Do link it here so we can see how it turns out .

I'm not sure if it's the same, but I posted the problem on WinFsp's Google Forums. https://groups.google.com/forum/#!topic/winfsp/m_7wag-55VQ

1 Like

Yep, one reply from the author of WinFsp and I figured out a driver installed by MS Software Certification Toolkit was causing the BSODs (SysTrace.sys). I uninstalled that , deleted the driver and both rclone and DFS work like a charm again! Thanks for the help : )

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.