Rclone mount over NFS on Windows


#1

I’ve read mixed results with this here in the forum. This is what I’m trying to do: mount a gdrive with crypt and share this mount over my network with NFS to my OPPO 203 player.

I’m trying to mount like this:
rclone mount secure: q: --allow-other --alow-non-empty --vfs-cache-mode writes.

And I’m using Hanewin NFS server to share q:\

Whe accessing from the OPPO it just hangs.

Any idea if it’s possible or if there’s something else I could try while mounting?


#2

There are some things in this thread about NFS & FUSE you could try.

NFS is generally quite fussy about what it exports…

Have you tried the NFS mount with a different client?


#3

I don’t have anything else that uses NFS here, except this player.

It also supports SMB 1.0 (for some reason it doesn’t support newer versions).
When I try to share the mount point on windows it gives me error.
I don’t know if SMB sharing is possible with rclone mount.

Do you think running a VM with Ubuntu on top of Windows 10 would be a good idea for sharing over NFS?


#4

I know people have shared rclone mount with samba on unix.

It might work, but you’ll have to try it and see!


#5

Do you know if I can use the same config file between systems?

Also, I have one small off topic question, but when launching complete movies from gdrive, like a Blu-ray, the player needs to read tons of small files, the same goes for games.
Looking at the background work with rclone mount it seems it’s just a single access each time.

My question is, is it possible for rclone mount to have something like 2 “workers” or read two files at the same time? Something like multi thread the access to gdrive?


#6

Rclone will handle many files just fine as it’s a multi threaded mount, not single file access.


#7

Had no idea. I’m just getting used to it.

Thanks, Animosity


#8

You can copy the rclone config file between systems. Find out where it is with rclone config file


#9

Did it here and it worked!

So explaining for other people that might want to do the same.
First my OPPO 203 is on custom firmware, so it can read BDMV and ISO from USB and LAN.

How it worked inside Windows 10.
Using HaneWin NFS you can export the mounted drive but no files are visible.
Using SMB you can’t share the mounted drive and using junction, symlinks won’t work.

What I did is:
Used VMWare Pro to boot a Ubuntu 18.04.
Bridged the network so it has it’s own ip address within my home network.
Tried NFS, it can see the folder but not the files. Someone mentioned that converting the fuse file system would work, I have no idea how to do this and seemed really complicated.

What worked is creating a SMB share, sharing it with the OPPO 203.
OPPO can see all the files and I was able to play a full disc BD UHD from Gdrive.
To me this was amazing.

The only caveat is that OPPO for the love of me, can’t use any user and password.
Tried everything and it worked from within windows 10 and it worked, but the oppo must have some bug that prevents it from using a username and a password.
Reading in the unofficial FAQ it claims OPPO uses SMB 1.0 so maybe the authentication is different.

What I did was make my mount point public and accessible by a guest account.
If someone knows how to make it access using a smb user and password, let me know.

But I call it a success and to me this is amazing.
My next step is try to play some games from gdrive, maybe some old games like Diablo cold be done, from within windows it’s not possible even setting folder and files permissions to 777.

Maybe from a share in linux it would be possible.