Rclone mount only syncs one way

I'm mounting my remote proton (Proton Drive, newcomer on rclone), with:

rclone mount --dir-cache-time=1000h --vfs-cache-mode=full --vfs-cache-max-size=150G --vfs-cache-max-age=12h --vfs-fast-fingerprint proton:SomeFolder ~/SomeFolder &

It mounts without problem, but the sync only goes one way: what I do in my local folder is immediately pushed to my browser's drive.proton.me, but nothing (creation, deletion, modification) I do on my cloud goes back down to my mounted folder...

So in summary local → cloud syncs well,
but there is no cloud → local sync at all.

> rclone version

rclone v1.64.2
- os/version: opensuse-tumbleweed (64 bit)
- os/kernel: 6.5.9-1-default (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.3
- go/linking: dynamic
- go/tags: none

It is the latest version of rclone.

> rclone redacted

type = webdav
url = https://cloud.ultome.me/remote.php/dav/files/ash
vendor = nextcloud
user = XXX
pass = XXX

type = drive
client_id = XXX
client_secret = XXX
scope = drive
export_formats = odt,ods,odp,svg
token = XXX
team_drive = 

type = webdav
url = https://cloud.ultome.me/remote.php/dav/
vendor = nextcloud
user = XXX
pass = XXX

type = protondrive
username = chrysostome.lanoire
password = XXX
mailbox_password = XXX
client_uid = XXX
client_access_token = XXX
client_refresh_token = XXX
client_salted_key_pass = XXX
replace_existing_draft = true

The command gives out no logs.


sorry, not sure exactly what you mean there?
the rclone mount folder is a local folder

can you provide an example?

Yes sorry I wrote the same thing twice. I'm editting my post.

sure, no problem, please let me know when you are done editing.

It's done please go and tell me if it's understandable now :slightly_smiling_face:

yes, that is expected behavior and a very common confusion the forum.
"changes made directly on the cloud storage by the web interface or a different copy of rclone will only be picked up once the directory cache expires"

check out my summary of the two rclone caches.

If you remove


Then your mount will be refreshed every 5minutes (default)

I'm sorry I don't really understand the content of your link... What should I do to have changes of my cloud instantaneously on my mounted folder? Please

instantaneously - that is not possible.

closest to instantaneously would be to change --dir-cache-time=1000h to --dir-cache-time=1s
tho that would use a lot more api calls and we already know how slow proton drive can be.

there are other workarounds, as i alredy detailed for you in

I'm sorry, but mounting with:

rclone mount --dir-cache-time=10s --vfs-cache-max-size=30G --vfs-cache-max-age=6h --vfs-fast-fingerprint --vfs-cache-mode=full --allow-other

Didn't help. The cloud still doesn't affect the locally mounted folder...

need to replicate the issue and post a full debug log.

Hm, after some more testing it seems it does work, just in more like a minute than 15s. I'll try some more and come back to you if there's a real issue worth your time. Thanks!

Back to the starting point. I found the behaviour of setting small intervals for --dir-cache-time very unreliable; what's more, I need a fast browsing so I think I need to stick with a high value for this flag (I put 1000h).

However, my problem is back:

  • Any file/folder created, either on my local mount, Android app or web browser, is almost instantaneously mirrored on the others;
  • but... any file/folder deleted from any of these services does not get deleted on the others, and stay there forever.

If I could solve this I'd be the happiest man on Earth, because it would mean I could work directly into a mounted rclone of my Proton Drive.


please, need to stop double-posting. very confusing.

in that other topic, you were asked to stop double-posting, but you continue to do so.
we are volunteers and you are making this too complicated for us.

so i am going to drop off this topic and post in that other topic, please do the same.

I will. Thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.