Rclone mount not showing anything in log file

What is the problem you are having with rclone?

log file

What is your rclone version (output from rclone version)

rclone v1.49.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

  • os/arch: linux/amd64

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gcrypt: /home5/joshk6656/mnt/gdrive --dir-cache-time=160h --buffer-size 256M --umask 002 --log-file /home5/joshk6656/logs/rclone_mount.log

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

2019/09/13 02:07:48 DEBUG : rclone: Version "v1.49.2" starting with parameters ["rclone" "-vv" "mount" "gcrypt:" "/home5/joshk6656/mnt/gdrive" "--dir-cache-time=160h" "--buffer-size" "256M" "--umask" "002" "--log-file" "/home5/joshk6656/logs/rclone_mount.log"]
2019/09/13 02:07:48 DEBUG : Using config file from "/home5/joshk6656/.config/rclone/rclone.conf"
2019/09/13 02:07:49 DEBUG : Encrypted drive 'gcrypt:': Mounting on "/home5/joshk6656/mnt/gdrive"
2019/09/13 02:07:49 DEBUG : Adding path "vfs/forget" to remote control registry
2019/09/13 02:07:49 DEBUG : Adding path "vfs/refresh" to remote control registry
2019/09/13 02:07:49 DEBUG : Adding path "vfs/poll-interval" to remote control registry
2019/09/13 02:07:49 DEBUG : : Root:
2019/09/13 02:07:49 DEBUG : : >Root: node=/, err=
2019/09/13 02:08:21 DEBUG : rclone: Version "v1.49.2" finishing with parameters ["rclone" "-vv" "mount" "gcrypt:" "/home5/joshk6656/mnt/gdrive" "--dir-cache-time=160h" "--buffer-size" "256M" "--umask" "002" "--log-file" "/home5/joshk6656/logs/rclone_mount.log"]

Interestingly enough, my log was always empty, until I added the -vv flag from that section above. Is this required to make the log file work?

1 Like

No, I usually just run INFO level or one -v.

You can see all the levels here:


But why doesn't this put anything in my log file?

rclone mount gcrypt: /home5/joshk6656/mnt/gdrive --dir-cache-time=160h --buffer-size 256M --umask 002 --log-level INFO --log-file "/home5/joshk6656/logs/rclone_mount.log"

INFO really doesn't display much. You'd have to copy a file or something to make an entry.

[felix@gemini Test]$ cp /etc/hosts .
[felix@gemini Test]$ cd
[felix@gemini ~]$ tail test.log
2019/09/12 20:32:31 INFO  : hosts: Copied (new)
[felix@gemini ~]$ ps -ef | grep Test
felix     4710 23590  0 20:31 pts/2    00:00:00 rclone mount gcrypt: /home/felix/Test --log-file test.log --log-level INFO
felix     4898  3829  0 20:32 pts/0    00:00:00 grep --color=auto Test

Well, I am trying to enable info so i can use the plex_rcs script so my libraries auto refresh after a file being copied, I have copied files, but have not seen an info entry yet.

Can you run the ps command like I did above and share the output?

If you copy a file in as an example, it'll write to the log if you have INFO on and the log file setup.

I was running the rclone without the -vv, and with --log-level INFO and the log was always empty. The first time I ever got info in my log was when I followed the question template to post in this section by adding -vv.

this is how i was running it before, with no output to log.

rclone mount gcrypt: /home5/joshk6656/mnt/gdrive --dir-cache-time=160h --buffer-size 256M --umask 002 --log-level INFO --log-file "/home5/joshk6656/logs/rclone_mount.log"

joshk66+ 16670 20483 0 02:11 pts/201 00:00:00 rclone -vv mount gcrypt: /home5/joshk6656/mnt/gdrive --dir-cache-time=160h --buffer-size 256M --umask 002 --log-file /home5/joshk6656/logs/rclone_mount.lo
joshk66+ 25133 35360 0 02:40 pts/187 00:00:00 grep --color=auto log
joshk66+ 25442 2736 4 Sep12 pts/211 00:10:42 python plex_rcs.py --logfile /home5/joshk6656/logs/rclone_mount.log
joshk66+ 25473 25442 0 Sep12 ? 00:00:00 /usr/bin/tail -Fn0 /home5/joshk6656/logs/rclone_mount.log
joshk66+ 29917 25121 0 02:15 pts/219 00:00:00 tail -F rclone_mount.log
joshk66+ 35847 34820 0 02:16 pts/223 00:00:00 tail -f rclone-upload.log

Is your paste not complete or is the g actually missing at the end?

You can use three backtics before and after a block to mark it like I did above so it doesn't format.

These things `

Put 3 of the above and below what you to mark

like this

-vv is the same as --log-level DEBUG so you should see quite a bit of output in the log.

Pretty much if you run in debug, you can see what are INFO messages:

2019/09/12 20:53:46 DEBUG : hosts: >Attr: a=valid=1s ino=0 size=0 mode=-rw-rw-r--, err=<nil>
2019/09/12 20:53:46 DEBUG : &{hosts (w)}: Write: len=254, offset=0
2019/09/12 20:53:46 DEBUG : &{hosts (w)}: >Write: written=254, err=<nil>
2019/09/12 20:53:46 DEBUG : &{hosts (w)}: Flush:
2019/09/12 20:53:46 DEBUG : Encrypted drive 'gcrypt:': File to upload is small (254 bytes), uploading instead of streaming
2019/09/12 20:53:48 INFO  : hosts: Copied (new)
2019/09/12 20:53:48 DEBUG : &{hosts (w)}: >Flush: err=<nil>
2019/09/12 20:53:48 DEBUG : &{hosts (w)}: Release:
2019/09/12 20:53:48 DEBUG : hosts: WriteFileHandle.Release nothing to do
2019/09/12 20:53:48 DEBUG : &{hosts (w)}: >Release: err=<nil>

Only the copy would show up INFO.

interesting, will it still pickup files copied via rclone copy?

I restarted my mount with:
rclone mount gcrypt: /home5/joshk6656/mnt/gdrive --dir-cache-time=160h --buffer-size 256M --umask 002 --log-level INFO --log-file "/home5/joshk6656/logs/rclone_mount.log"

And did the following, and the info was there...

Do you have any recommendations on how to refresh my plex after a rclone copy?

My setup is....
Download to seedbox manually > rclone copy files to gdrive.

I've read about sonarr / radarr, but I do not use either of those to add files.

This should do it:

I believe Stokkes program was more for the cache backend and if things expire there? I'm not sure as I've never used it.

I've looked through this a few times, but is there a configuration where it works without sonarr/radarr? Also one that doesn't require root access?

That other one was written initially for cache, but later vfs support was added. No one has really posted about that working though.

This part:

Guess I didn't look hard enough.

Thank you, I will give this a shot. This setup guide is intense!

Also, thanks for the info on your wiki page, wouldn't have made it this far without it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.