Rclone mount not displaying unicode characters properly

What is the problem you are having with rclone?

when mounting a remote the directories or filenames that have the special character "?" in their name is shown up as "" instead any ideas how I can fix this? I have enabled unicode_normalization = true in the local remotes but it doesn't do anything to help with displaying the character properly.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0

  • os/version: Microsoft Windows 10 Pro 22H2 (64 bit)
  • os/kernel: 10.0.19045.3693 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount union: H: --vfs-cache-mode off --dir-cache-time=5s --buffer-size 1G --network-mode -vv
type = local
local_root = \\\disk1\Backup

type = local
local_root = \\\disk2\Backup

type = local
local_root = \\\disk3\Backup

type = local
local_root = \\\disk4\Backup

type = local
local_root = \\\disk5\Backup

type = union
action_policy = mfs
create_policy = mfs
search_policy = mfs
cache_time = 120
upstreams = Disk1:\\\disk1\Backup Disk2:\\\disk2\Backup Disk3:\\\disk3\Backup Disk4:\\\disk4\Backup Disk5:\\\disk5\Backup

Probably related to Windows local encoding.

Try to add encoding option to your config:

type = local
local_root = \\\disk1\Backup
encoding = "Slash,LtGt,DoubleQuote,Pipe,BackSlash,Ctl,RightSpace,RightPeriod,InvalidUtf8,Dot"

Looks like its fixed it with adding the flag "--local-encoding None" when mounting the union.

Ended up using the command "rclone mount UnraidDiskUnion: H: --vfs-cache-mode off --dir-cache-time=5s --buffer-size 1G --network-mode --local-encoding "Slash,Ctl,RightSpace,RightPeriod,InvalidUtf8,Dot" --log-level INFO" as for some reason unicode characters in file/folder name if set in the local encoding will show up as "". Would have thought setting the local-encoding for those unicode characters would only be for turning illegal characters into the alternative unicode ones.

Now seems to work well, also to note turning --vfs-cache-mode full seems to cause performance issues when opening folders with files that are very large (1TB+ in size) as it seems to try and read them all and cause windows explorer to not respond. Not sure if its trying to hash all files in the opened folder with that flag set.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.