Rclone mount much slower than rclone copy

What is the problem you are having with rclone?

Using a Gigabit connection I can get about 70MB/s but using the mount command I can never exceed around 20-21MB/s.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.2

  • os/version: debian 11.5 (64 bit)
  • os/kernel: 5.19.0-1-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.18.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive Education Account

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone mount remote:Media/ /mnt/rclone --allow-other --gid=1000 \
--uid=1000 --dir-cache-time 6570h --poll-interval 1m \
--fast-list --buffer-size 128M --drive-chunk-size 128M --cache-dir=/root/rclone-chunk1/ --dir-cache-time 500h \
--cache-info-age=300h --vfs-cache-mode writes --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 2G --vfs-cache-max-age 48h \
--drive-pacer-min-sleep 20ms --drive-pacer-burst 50 --vfs-cache-max-size 100G --vfs-read-ahead 2G \
--umask 002 --log-level DEBUG --user-agent rclone --log-file=/var/log/rclone.log

The rclone config contents with secrets removed.


A log from the command with the -vv flag


I have tried modifying lots of vfs cache and chunk size parameters but with no effect.
Removing all non essential parameters from the mount command does not help either.
Resource usage seems low. Please see attached screenshots

Thank you in advance!

The logs attached are during a copy. I have tried setting the destination to the SSD and to /dev/null.
There seems to be a bottleneck somewhere. I can see iowait but I assume this is to be expected with a network fuse filesystem.
Changing the user-agent does not seem to help either.

I understand that running a copy command is usually slower than a native rclone command as it will be single threaded. Would this be the cause? Is there no way to speed this up as I am using this for Jellyfin.

Please let me know if I can provide any more information.

That's one busy mount command. I always start with less is more.

2022/10/15 11:19:01 NOTICE: --fast-list does nothing on a mount

You can remove that.

That won't change much as you are using cache mode writes so if you are reading, nothing will ever be written to disk.

Mounts are a single threaded so you are only getting 1 stream downloading at a time so if something isn't performing well, you'd see some issues.


Is for the cache backend, which you aren't using.

Are you seeing any other system bottlenecks while things are running?

How are you testing the mount speed? What command?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.