Rclone mount + keepass trash the file after every save

When I still used Windows 7, I had keepass + google drive file stream, and I could work with the remote database just fine, and it would sync and I'd be able to access it using keepass2android just fine.

Now with linux desktop and a rclone mount. Everytime I save the file, its sent to the trash and a new one is created

image

This makes keepass2android unable to sync the updates with the error : file is trashed.

I want the old behavior where the file would be just edited. Why is this happening?

  --user-agent='Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36' \
  --config=/redacted \
  --allow-other \
  --rc \
  --rc-addr=localhost:5572 \
  --fast-list \
  --vfs-read-chunk-size=64M \
  --vfs-read-chunk-size-limit=2048M \
  --buffer-size=64M \
  --poll-interval=1m \
  --dir-cache-time=168h \
  --timeout=10m \
  --drive-chunk-size=32M \
  --umask=002 \
  --syslog \
  --vfs-cache-mode=writes \
  --cache-dir=/dev/shm \
  -v \

This is my settings

hi, i do a simlar thing but in a different way.

so you are using a single .kdbx saved on a mount and want to share that one .kdbx between local keepass and keepass2android at the same time?

what version of rclone are you running?

here is how i do it.
local computer: rclone sync the .kdbx from local to cloud
android: rclone sync the .kdbx from cloud to phone for keepass2android.offline
i run rclone on android using termux.
on local computer i use rclone sync, not rclone mount
and on android, i use rclone sync using termux.

What's the debug log say when you hit save? The info would be there.

I don't want to run sync, I want to use a mount so is always automatically saved to google drive.

And if it just edit the file, instead of creating another one, it won't cause issues with keepass2android

What version of rclone are you using?

Did this work as you expected in a previous version?