Rclone Mount Google Drive stop silently (Hcloud)

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

Rclone Stop Mounting when plex start with his scheduled task.
I have 3 mounted google drive and only one appear to cause problem the Nº3.
It quits silently without any real log information, it only exist, making the directory busy (need to do a umount on the host) while exiting.

Run the command 'rclone version' and share the full output of the command.

Just for information i'm using Kuber-Rclone (Kubernetes Rclone) wish use the "rclone/rclone:beta" version of docker container.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount 'Cloud Storage Server 3 Uncrypt:/' '/mnt/Cloud Storage/Cloud Storage Server 3/' --config=/etc/rclone/rclone.conf --allow-non-empty --allow-other --log-file=/config/rclone/rclonemount3.txt --log-level DEBUG

I will try without the --allow-non-empty option this night also.

The rclone config contents with secrets removed.

[Cloud Storage 3]
type = drive
client_id = *******************
client_secret = ************
scope = drive
token = ***************
team_drive = *********
root_folder_id = 

# I know this is deprecated so now we should use vfs btw, but we are remaining with old setups until now.

[Cache Cloud Storage 3]
type = cache
remote = Cloud Storage 3:
chunk_size = 32M
info_age = 24h
chunk_total_size = 30G
db_path = /config/rclone/cache-backend/
chunk_path = /config/rclone/cache-backend

[Cloud Storage Server 3 Uncrypt]
type = crypt
remote = Cache Cloud Storage 3:/
filename_encryption = standard
directory_name_encryption = true
password = *******************
password2 = *******************

A log from the command with the -vv flag

Log here

The kube-rclone repo:

Please note, the container they have in the yml is not the same as i use, mine is "rclone/rclone:beta" btw.

It uses rclone v1.53.1 from 2020.... Could you update it first to the latest version? (1.62.2 now)

Like said in the post i use the repository "rclone/rclone:beta" so it use the latest in beta on docker hub.

You mentioned 3 gdrives. Are two other working one configured in the same way using mounted cache remote?

And what does it exactly mean? Then it works initially and then stops later?

Yeah all team drives are in the same node, and configured the same way with k8s and the rclone/rclone:beta container image registry,

I mean, it work during 24h and them rclone exit the process, and fuse make it no more a accessible directory, the directory still in busy procress i need to unmout with fuse to mount it and make the directory reachable and mount it again

It should say at the end of the log what the problem was.

If it doesn't then maybe the OS killed it.

Using too much memory is the usual suspect.

In fact the memory on rancher is at (4gb / 7gb) on the rclone node i will upgrade the RAM on the node to see if that helps :frowning_face: need to speend some additional $$$

see picture

I need to monitor the RAM, with grafana or netdata. to see if the problem comes relly from there :wink:

I already trigger allert when one of the mounts is down with grafana and prometheus btw.

Is there any way to decrease the Memory consumption from rclone ?
On the config or on a k8s pod limit.

After making my own research on metric of rancher i can see than there is a unusual spike at 3h a.m consuming 90% of ram as picture attached here

I go to increase ram to see if it works better

There is a FAQ with some tips in.

I see you are using the cache backend also and this could be the cause of the excess memory usage.

We don't recommend that now instead we recommend you remove it and add --vfs-cache-mode full to your rclone mount command. It should be as simple as that! Though you'll probably want to set some of these.

  --vfs-cache-max-size SizeSuffix          Max total size of objects in the cache (default off)
  --dir-cache-time Duration                Time to cache directory entries for (default 5m0s)
  --vfs-cache-max-age Duration             Max time since last access of objects in the cache (default 1h0m0s)
  --cache-dir string   Directory rclone will use for caching

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.