Rclone mount freezes after upload of multiple files


#1

Hello everyone,

I’m mounting my rclone drive on Windows and it mounts properly.
I have a problem when I copy multiple files (at the moment pictures to my encrypted volume), then after a short time rclone is getting stuck. So after 30-60 pictures (each around 1MB) is just stops copying the files. The dialog is still there but no new files will be copied. In the meantime I can easily access the folders in a new explorer window.

I tried with the very basic command:
rclone mount gdencrypted:/ M: --vfs-cache-mode writes

I also tried with with the parameters from a thread found here with the optimum parameters to mount Google Drive:

rclone mount ^
–vfs-cache-mode writes ^
–allow-other ^
–rc ^
–size-only ^
–dir-cache-time=2m ^
–vfs-read-chunk-size=64M ^
–vfs-cache-max-age 675h ^
–vfs-read-chunk-size-limit=1G ^
–buffer-size=32M ^
–log-level INFO ^
–timeout 5s ^
–contimeout 5s ^
gdencrypted:/ M:

Both have the same result. Has someone any idea why this is happening? And even better how I can stop that? :wink:

Thank you and best regards


#2

You need to share a log or we’d be guessing. Use -vv


#3

We’ve put lots of fixes into rclone mount on Windows recently and fixing hangs was one of them. I recommend you try the latest beta;


#4

Thank you @calisro and @ncw , just finished logging when @ncw postet about the new beta.

Seems like this is fixed in the update.
With the latest beta I uploaded now already around 1.5 GB and around 600 files without any interruption!