Rclone mount flags not recognised

What is the problem you are having with rclone?

Hi. I've been using rclone, specifically the mount command, to access files located on Google Drive. I haven't updated rclone in a few years, nor my implementation of it. Typically after a restart, I run the same command to re-mount my drive (as pasted below), however after my most recent restart I have found that several of the flags I typically use (i.e. the vfs, poll-interval, cache-dir etc.) flags are not being recognised with the error Fatal error: unknown flag: --poll-interval being thrown when attempting to run the command. Would appreciate any help, thanks!

Run the command 'rclone version' and share the full output of the command.


Which cloud storage system are you using? (eg Google Drive)

google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount wx:yz /home/wxyz --allow-other --dir-cache-time=4h  --log-file /root/rclone.log --poll-interval=15s --umask 002 --user-agent wxyz --cache-dir=/root/drive-cache --vfs-cache-mode full --vfs-cache-max-size=100G --vfs-cache-max-age=4h --log-level INFO --vfs-cache-poll-interval 15s --cache-db-purge

The rclone config contents with secrets removed.

type = drive
client_id = somestuffhere
client_secret = somestuffhere
scope = drive
token = {"access_token":somestuffhere","token_type":"Bearer","refresh_token":"somestuffhere","expiry":"sometimestamphere"}
team_drive = somestuffhere
root_folder_id =

hello and welcome to the forum,

can update to latest stable v1.62.2

that is for the deprecated cache remote, which based on your config, not using.

1 Like

Hey, this worked, thanks a ton!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.