Rclone mount fails to properly mount

What is the problem you are having with rclone?

I am trying to mount my Hetzner storage box on a server. While my hetzner remote is properly set up and I can for example run rclone ls and see files in my remote, when I mount it the mount directory is empty. The debug log (below) shows >Root: node=/, err=<nil>.

Run the command 'rclone version' and share the full output of the command.

rclone v1.66.0
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 6.5.0-1019-oracle (aarch64)
- os/type: linux
- os/arch: arm64 (ARMv8 compatible)
- go/version: go1.22.1
- go/linking: static
- go/tags: none

Are you on the latest version of rclone?
Yes

Which cloud storage system are you using? (eg Google Drive)

Hetzner Storage

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I've started off with a lot more flags but I've whittled it down to this:

rclone mount hetzner:/path/to/directory ~/local_directory -vv     

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[hetzner]
type = sftp
host = XXX
user = XXX
port = 23
pass = XXX
md5sum_command = md5 -r
sha1sum_command = sha1 -r
shell_type = unix

A log from the command that you were trying to run with the -vv flag

2024/03/29 02:59:40 DEBUG : rclone: Version "v1.66.0" starting with parameters ["rclone" "mount" "path/to/directory" "~/local_directory" "-vv"]
2024/03/29 02:59:40 DEBUG : Creating backend with remote "path/to/directory"
2024/03/29 02:59:40 DEBUG : Using config file from "REDACTED"
2024/03/29 02:59:41 DEBUG : sftp://REDACTED@REDACTED.your-storagebox.de:23//path/to/directory: New connection REDACTED->REDACTED to "SSH-2.0-OpenSSH_9.3 FreeBSD-20230719"
2024/03/29 02:59:41 DEBUG : sftp://REDACTED@REDACTED.your-storagebox.de:23//path/to/directory: Shell type "unix" from config
2024/03/29 02:59:41 DEBUG : sftp://REDACTED@REDACTED.your-storagebox.de:23//path/to/directory: Using root directory "/path/to/directory"
2024/03/29 02:59:41 INFO  : sftp://REDACTED@REDACTED.your-storagebox.de:23//path/to/directory: poll-interval is not supported by this remote
2024/03/29 02:59:41 DEBUG : sftp://REDACTED@REDACTED.your-storagebox.de:23//path/to/directory: Mounting on "~/local_directory"
2024/03/29 02:59:41 DEBUG : : Root: 
2024/03/29 02:59:41 DEBUG : : >Root: node=/, err=<nil>

When i run rclone ls hetzner:path/to/directory':

     4799 port-tool.py
        0 test

When I run 'ls local_directory` it shows nothing

Output of df -h | grep hetzner :

hetzner:/path/to/directory     16E     0   16E   0% /home/ubuntu/local_directory

I also have no problem doing a regular sftp mount.

Been racking my brain for a day so would appreciate if greater minds can take a look or give me some further troubleshooting ideas :slight_smile:

any reason you make it different?

and

??

Try

mount hetzner:path/to/directory

The log above is from running

I just put the output of rclone ls to show that it was able to access the remote and that the problem seems to be with mount in particular and the configuration of my remote. It also shows the files that should appear in ~/local_directory when the mount works correctly (currently nothing appears in that directory)

your ls and mount do not point to the same place.... so results are different.

Oh my god, hours and hours of racking my brain and it was just a misplaced \.

Thanks for bearing with me, I'm an idiot :slight_smile:

1 Like

hi,
is the server a hetzner vm? if so, might be better options than sftp