Rclone mount download performance on synology

What is the problem you are having with rclone?

When running my rclone mount on an sftp backend and download files, I am only receiving about 5 MB/s downspeed. When downloading the file via SFTP directly (without a mount), I am seeing 15 MB/s or more.

I'd like to know if there is a cache setting that I need to modify. I am generally downloading 1 GB or larger files using rclone. Very little write operations as I am syncing from a remote system.

This is running on a Synology 920+ with 8 GB of RAM.

Run the command 'rclone version' and share the full output of the command.

$ rclone version
rclone v1.58.0
- os/version: unknown
- os/kernel: 4.4.180+ (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.8
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

SFTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount -v --stats 1m --stats-one-line remote:/path/to/folder /volume1/Media/mount --allow-other --dir-cache-time 5m --vfs-cache-mode full --cache-dir /volume1/Media/mount/.cache --config /volume1/user/.config/rclone.conf

The rclone config contents with secrets removed.

[remote]
type = sftp
host = IP_ADDRESS
user = user
port = 11111
key_file = /volume1/user/.config/cert.pem
use_insecure_cipher = true
key_file_pass = SECRET
md5sum_command = md5sum
sha1sum_command = sha1sum```

hello and welcome to the forum,

fwiw, might test the following setup
for downloads only, can use
--- --read-only
--- not use the rclone vfs file cache, the default value of --vfs-cache-mode=off

i could be wrong, that
with rclone mount, downloads a single file at a time.
whereas rclone copy, downloads multiple files at the same time.

Let me give it a go with the cache off. I do SOME writes to the remote, but not a lot.

rclone mount definitely seems to be downloading one file at a time.

I am using sonarr, so I may have to try and see if I can trigger an rclone script instead of relying on a mount and remote.

Edit: Looks like disabling cache didn't help at all. I did do a test of rclone copy and I am getting much closer to the expected speeds.

How are you testing the download speed via the mount?

Note that mounts usually only do single threaded download whereas rclone copy will do multithreaded downloads.

I was just monitoring the speed of downloading a large file that was done on the mount.

It sounds like mount might not be the most efficient way. I will tinker with sonarr and see if I can disable import and just use a copy or something. Thanks for the help!

1 Like