Rclone mount doesn't work with Docker on ARM

What is the problem you are having with rclone?

rclone mount doesn't work on ARM using Docker but it works if I mount it directly

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0

  • os/version: alpine 3.14.2 (64 bit)
  • os/kernel: 5.13.0-1021-oracle (aarch64)
  • os/type: linux
  • os/arch: arm64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

version: "3.7"

        image: rclone/rclone:latest
        container_name: enc
            - PUID=1000
            - PGID=1000
            - /home/ubuntu/.config/rclone:/config/rclone
            - /home/ubuntu/Enc:/data/enc:shared
            - /etc/passwd:/etc/passwd:ro
            - /etc/group:/etc/group:ro
            - /dev/fuse
            - SYS_ADMIN
            - apparmor:unconfined
        command: "mount enc: /data/enc --allow-other --allow-root --allow-non-empty --vfs-cache-mode writes --transfers 15 --vfs-write-back 1s --vfs-cache-max-age 5m --vfs-cache-max-size 10G --vfs-write-wait 3s"
        restart: unless-stopped
                    memory: 8G

The rclone config contents with secrets removed.

type = drive
client_id = xyz
client_secret = xyz
scope = drive
token = {"access_token":"xyz"}
team_drive = 

type = crypt
remote = drive:Enc
filename_encryption = off
directory_name_encryption = false
password = xyz

A log from the command with the -vv flag

2022/03/18 20:55:20 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "mount" "enc:" "/data/enc" "--allow-other" "--allow-root" "--allow-non-empty" "--vfs-cache-mode" "writes" "--transfers" "15" "--vfs-write-back" "1s" "--vfs-cache-max-age" "5m" "--vfs-cache-max-size" "10G" "--vfs-write-wait" "3s" "-vv"]
2022/03/18 20:55:20 DEBUG : Creating backend with remote "enc:"
2022/03/18 20:55:20 DEBUG : Using config file from "/config/rclone/rclone.conf"
2022/03/18 20:55:20 DEBUG : Creating backend with remote "drive:Enc"
2022/03/18 20:55:20 DEBUG : Google drive root 'Enc': 'root_folder_id = xyz' - save this in the config to speed up startup
2022/03/18 20:55:21 DEBUG : vfs cache: root is "/root/.cache/rclone"
2022/03/18 20:55:21 DEBUG : vfs cache: data root is "/root/.cache/rclone/vfs/enc"
2022/03/18 20:55:21 DEBUG : vfs cache: metadata root is "/root/.cache/rclone/vfsMeta/enc"
2022/03/18 20:55:21 DEBUG : Creating backend with remote "/root/.cache/rclone/vfs/enc/"
2022/03/18 20:55:21 DEBUG : Creating backend with remote "/root/.cache/rclone/vfsMeta/enc/"
2022/03/18 20:55:21 DEBUG : Encrypted drive 'enc:': Mounting on "/data/enc"
2022/03/18 20:55:21 ERROR : Ignoring --allow-root. Support has been removed upstream - see https://github.com/bazil/fuse/issues/144 for more info
2022/03/18 20:55:21 INFO  : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)
2022/03/18 20:55:21 DEBUG : : Root:
2022/03/18 20:55:21 DEBUG : : >Root: node=/, err=<nil>

i assume that rclone debug log is from the command line, is that correct?

if so,

what does that mean, can you explain in detail?
where is the rclone debug log or docker log?

The logs with the -vv flag are the ones that result from running docker logs enc

ok, what is the exact problem?

That it doesn't seem to actually mount the remote. When I ls the directory it is empty, doesn't show anything

then post the exact command and full ouput from the command line.
please understand that we cannot see into your computer.


not an expert with docker,
but the first step is to remove all errors with the rclone mount command.

I just tried with two different x86/AMD64 servers and it doesn't work either. I think it's a bug with the latest version

This is usually caused by not setting it up as a shared mount properly. Check out these docs and try some of the other options.

what was the older version of rclone that worked for you?

and the latest version of rclone is v1.58.0, not v1.57.0.
v1.58.0 was uploaded yesterday.

Sorry, it was actually a problem with docker compose since it worked if I used docker run. It worked with docker compose version 1.29.2 but after upgrading to version 2.3.3 it didn't anymore. I fixed it by specifying the type of bind as explained in this post: Docker-compose - Rclone Data mount not accessible on host - #7 by GettingTechnicl

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.