Rclone mount as Veeam repository?

A drive letter has been assigned to a drive mounted with rclone mount, e.g. Z:

However, this drive Z: is not shown in Veeam when selecting the available drives for a repository.

The mounting takes place under the same user account as the Veeam services.

I assume that the reason is that Veeam does not recognize rclone fuse-mounts. On the other hand, Veeam also describes fuse mounts for Linux clients.

Has anyone been able to integrate rclone mounts under Veeam as a backup repository?

try running rclone mount as system user.

i use veeam and rclone every day. veeam agent and veeam backup and replication.

if you pay for veeam, it can backup its own files to the cloud.

i use the free editions of veeam, which will not backup to cloud.

rclone mounts are very slow and not good with lots of random access of small amounts of data.
in addition, if you plan to upload large .vib and .vbk files, rclone mount cannot handle internet glitches well and retries.

i run veeam backup and after the backup is done, i use rclone copy the backup files to the cloud.

Letting the user run under the system accound didn't change anything. As I wrote before, Veeam ran under the same user account as the one who rclone mounted. So it was actually clear that it couldn't be up to the user. Thanks anyway for the hint.

Did you actually get the drive letter (for me: G:) of the folder mounted by rclone to be displayed in Veeam when selecting the backup repository?

I don't see the drive letter:

PS: and, yes, we had included a Veeam cloud provider in the Veeam 9 enterprise version (a single cloud provider was always too little for us) and ran rclone in a post-backup script (which time ended with and without errors). Hence the idea to integrate several cloud providers (e.g. GCS, Backblaze, Azure) directly into Veeam via mounted drives

if i understand, you already have a working post backup script running rclone,
then you do you want to use mount?

another reason not to use rclone mount is ransomware and cyber attacks.
you will not be able to receover from ransomware

if you have your backups accessible as a drive letter, then if your server gets hacked, the ransomware software will encrypt all your data and encrypt all your backups.

yes, VBAR can see the mounted drive x:
what is your mount command?


rclone mount GDrive_enc: g:

  1. try adding flag --allow-other.
  2. run rclone mount as system user

Unfortunately, it didn't change either

you tried as running rclone mount system user?

i was able to get VBAR to accept a rclone mount as backup repository

@asdffdsa Could you tell us how?
I can see the mounted drive (setup via nssm as system acc & --allow-other ).
But i get "invalid folder path" when i try to set the backup storage.

hello and welcome to the forum,
on windows, --allow-other does nothing,

as for the the veeam repository, i did get that to work and veeam to backup to it.
but every time, the backup failed.

in the past, i setup a VTL using an aws server.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.