Rclone mount and mergerfs help

i run script mergerfs :::

mergerfs /mnt/siambit:/mnt/gdrive /mnt/gmedia -o rw,sync_read,allow_other,category.action=all,category.create=ff


rclone mount :::


gmedia.service :::

Description=gmedia mergerfs mount

ExecStart=/usr/bin/mergerfs /mnt/siambit:/mnt/gdrive /mnt/gmedia -o rw,async_read=false,use_ino,allow_other,func.getattr=newest,category.action=all,category.create=ff,cache.files=partial,dropcacheonclose=true


help me.

Do you want to run that as root?

What is the error if you run it just from the command line? Does it work?

yes i run root.

script :::

/usr/bin/mergerfs /mnt/siambit:/mnt/gdrive /mnt/gmedia -o rw,async_read=false,use_ino,allow_other,func.getattr=newest,category.action=all,category.create=ff,cache.files=partial,dropcacheonclose=true

error :::

script :::

mergerfs /mnt/siambit:/mnt/gdrive /mnt/gmedia -o rw,sync_read,allow_other,category.action=all,category.create=ff

don't error.

Do you have multiple versions of mergerfs installed?

What does:

root@gemini:~# /usr/bin/mergerfs -V
mergerfs version: 2.29.0
FUSE library version: 2.9.7-mergerfs_2.29.0
fusermount version: 2.9.7-mergerfs_2.29.0
using FUSE kernel interface version 7.31


The error you have in the script is because you have an old version. How did you install it?

i install script use

sudo apt install mergerfs on ubuntu server 18.04.4 lts

That's an old version in the repo and not recommended to install that way.

It's best to grab the latest release from the repo for your system and use dpkg to install it.

ubuntu server 18.04.4 LTS choose downloads ?

I assume you are using some Intel base server so:


This shows what version you are running with the name:

root@gemini:~# lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 10 (buster)
Release:	10
Codename:	buster
1 Like

root@media:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.4 LTS
Release: 18.04
Codename: bionic

mergerfs work, Thanks for help. :heart_eyes: :heart_eyes: :heart_eyes:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.