Rclone makes another directory with the same name on the remote

What is the problem you are having with rclone?

So someone has shared with me a folder and I'm trying to upload that folder to another account (remote) to do so I'm using the command I've posted below. Now, two things:

  • The directory was shared to another account of mine so I'm copying from one account/remote (that has the shared dir) to another account/remote (that is encrypted).
  • The crypt remote is pointing to a directory named "Folder_B" (that's the root of the crypt remote) inside that there is already a "Folder A" directory and rclone instead of creating the "Shared_name" directory in there is creating another "Folder_B" and doing all the operations there so I end up with two "Folder_B" directories in my drive.

Can someone test something similar? I don't understand why rclone created another Folder_B.

What is your rclone version (output from rclone version)

1.56.1

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy remote_with_shared:Shared_Name "crypt_remote:Folder A\Shared_Name" --update --checksum --no-update-modtime --transfers 12 --checkers 14 --contimeout 60s --timeout 300s --retries 3 --low-level-retries 10 --create-empty-src-dirs --drive-chunk-size 128M --drive-shared-with-me

The rclone config contents with secrets removed.

[Google Drive]
type = drive
client_id = REDACTED
client_secret = REDACTED
scope = drive
token = REDACTED

[crypt_remote]
type = crypt
remote = Google Drive:Folder_B
filename_encryption = standard
directory_name_encryption = true
password = REDACTED
password2 = REDACTED

[remote_with_shared]
type = drive
client_id = REDACTED
client_secret = REDACTED
scope = drive
root_folder_id = rclone
token = REDACTED
team_drive = 

A log from the command with the -vv flag

I don't have any, I stopped the operation when I realized what was happening.

Known issue:

1 Like

thanks! I'm subscribing to that issue now

@litson check out this comment which has a pretty good workaround

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.