Rclone loses mount

What is the problem you are having with rclone?

Rclone loses mount.

What is your rclone version (output from rclone version)

rclone v1.52.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

os/arch: linux/amd64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

sudo /share/CACHEDEV3_DATA/.qpkg/RClone/rclone mount --log-level INFO --allow-other --allow-non-empty --tpslimit 10 --tpslimit-burst 10 --dir-cache-time=48h --buffer-size=64M --attr-timeout=1s --vfs-read-chunk-size=64M --vfs-read-chunk-size-limit=2G --vfs-cache-max-age=5m --vfs-cache-mode=writes --cache-dir /share/CACHEDEV3_DATA/rclonenas --config=/share/homes/admin/.config/rclone/rclone.conf --user-agent=NAS --cache-workers 8 nasdrive: /share/homes/admin/Nasdrive &

Paste command here

The rclone config contents with secrets removed.

Enter a Team Drive ID> 1

type = drive
client_id = xxxxxxxxxxxxxxx4eusorujr0au4ho9ebf2v2q7s.apps.googleusercontent.com
client_secret = xxxxxxxxxxxxxJ3LCrt5tu0OR
token = {"access_token":"ya29.axxxxxxxxxxx_EQaf4xtfAfwDwaLIjGDWEJFfEpIwbSgoBUAn_I1j5AsP-PLxsUTrcxcWWarAgM9smjLqEetrDk-sIXc2lHSyZmpnbPb3VXfSLnfRh7h4-XRwv7xyjw4xotrZxZggJPNfWl3oD8g","token_type":"Bearer","refresh_token":"1//03WvqO4fq9j_UCgYIARAAGAMSNwF-L9Ird_cr0w3FLiaypJzzJ4k7EDUa7McLF1jL9uU0mQv4TJsKd7OavqIg24ZgCb5Kppcd1n8","expiry":"2020-05-28T11:11:04.850127036+02:00"}
team_drive = 0AMKUF165n6feUk9PVA

Enter a Team Drive ID> 2

type = drive
client_id = xxxxxxxxxxxxxxx4eusorujr0au4ho9ebf2v2q7s.apps.googleusercontent.com
client_secret = xxxxxxxxxxxxxJ3LCrt5tu0OR
token = {"access_token":"ya29.a0AfH6SMBxwScORBpksiG4QlqQ85DOBhcTt6ayZUGLLMsqFUldSOxms9ZxIavl4H1xq8qvia7AoSBC8MkowTMhSZprbztPHaRoHiAwSVKLOcobaorL_P71hTGLnLtfLGkWd_cY6oarCZASF67ygdw_HIx9DZoxmQ5NuLI","token_type":"Bearer","refresh_token":"1//03fFrTsMJJNyHCgYIARAAGAMSNwF-L9IrJ0QOtCgLDMLsFmjynnGePZBa0YsJNuql75Ek7B6vc-YI01TVpU4fVHAJmYT3DG2YRYU","expiry":"2020-05-28T11:07:07.10323543+02:00"}
team_drive = 0AKA5Fgw-YBNhUk9PVA

Enter a Team Drive ID> 3

type = drive
client_id = xxxxxxxxxxxxxxx4eusorujr0au4ho9ebf2v2q7s.apps.googleusercontent.com
client_secret = xxxxxxxxxxxxxJ3LCrt5tu0OR
scope = drive
token = {"access_token":"ya29.a0AfH6SMDEme1RF9499i_JuCfUY42RZDhz33psAh7Oth7dhX-2XIgPgbvtwVhCo66LNTJcplEZDPHLUbLZaSug08jJ2yrGJ07GxHWeLAk6iW3fCbLC-ebJyc7lZEM46CboRYwKnQkL43sTVZO4E03dCIOgrjjXz6F7ukw","token_type":"Bearer","refresh_token":"1//03YnIdwSij35eCgYIARAAGAMSNwF-L9IruHNPz3CPUbKjrOzVcDWUApeAdZcnlI9f3TVGaGfppu26NWfKanooFYtK2p4Ueeq6FhM","expiry":"2020-06-14T19:57:39.856250715+02:00"}
team_drive = 0AH7zEKoeUwHEUk9PVA

A log from the command with the -vv flag

Hello good afternoon, my regards. I wanted to please ask for help with a unit disassembly problem, just like the other colleagues in the group. I have a qnap NAS where I have installed the rclone app from the unofficial repository, everything working perfectly until a week ago the units were disassembled.

The log file you only have these lines written to me: 2020/06/18 01:40:48 INFO: Starting HTTP transaction limiter: max 10 transactions / s with burst 10
2020/06/18 01:40:50 mount helper error: fusermount: failed to access mountpoint / share / CACHEDEV3_DATA / homes / admin / Nasdrive: Transport endpoint is not connected
2020/06/18 01:40:50 Fatal error: failed to mount FUSE fs: fusermount: exit status 1.

The command I use to mount the drives is: sudo /share/CACHEDEV3_DATA/.qpkg/RClone/rclone mount --log-level INFO --allow-other --allow-non-empty --tpslimit-burst 10 --dir-cache-time = 48h --buffer-size = 64M --attr-timeout = 1s --vfs-read-chunk-size = 64M --vfs-read-chunk-size-limit = 2G - vfs-cache-max-age = 5m --vfs-cache-mode = writes --cache-dir / share / CACHEDEV3_DATA / rclonenas --config = / share / homes / admin / .config / rclone / rclone.conf - user-agent = NAS --cache-workers 8 nasdrive: / share / homes / admin / Nasdrive &.

Any help you can give me to solve this error, or what other way do I have to mount the units since I am using this tutorial to mount the units, inside the RClone.sh in the start and stop lines, to mount and unmount after every restart.

This would be the tutorial that I use but not the mount command, since it did not work for me: https://www.forocoches.com/foro/showthread.php?t=7314691

Paste  log here

Unfortunately, I really have a hard time following that guide as it's pretty bad and generally bad :frowning_face:

You'd probably want to take a step back and go simple and remove the cache from the process.

From your mount setup, you don't seem to have a cache configuration setup and have a bunch of cache parameters too.

So take your long command and slim it down:

sudo /share/CACHEDEV3_DATA/.qpkg/RClone/rclone mount --log-level INFO --log-file /share/homes/admin/rclone.log --allow-other --dir-cache-time = 48h --buffer-size = 64M  --vfs-cache-mode = writes --cache-dir /share/CACHEDEV3_DATA/ rclonenas --config=/share/homes/admin/.config/rclone/rclone.conf nasdrive: /share/homes/ admin/Nasdrive --daemon

I think I got that right from pasting your stuff back together. I added in a log file path so we can see the log file. I also removed the "&" and just ran it as a deamon so it'll go in the background.

You want to make sure you mount location is empty.

The error you shared usually means you have/had multiple rclones running so you want to stop them and make sure you are starting clean.

Hello good afternoon, could you tell me a cleaner mount, without having so many parameters in the mount and how do I add a path for the log file?
What I do have are several mounted units

I think I did above as I'd use that if you check out the command, it has the log file in it.

If I have noticed when comparing it with the original, I have reassembled them, only that in a unit it did not mount it and the registry file puts this: 2020/06/20 22:44:29 Fatal error: Directory is not empty: / share / homes / admin / Nasusal If you want to mount it anyway use: --allow-non-empty option.

I put the parameter that was telling me and got on. Now my problem is how to automate it so that when I restart the nas, they are remounted.
Would you have any suggestion?

Thank you very much

You'd make sure the mount point is empty. Does something recreate files there?

I don't understand what you mean by the question

If you do a 'ls' in the mount place, what's in there? Are there files?

Are you putting files there before the mount happens?

in that unit there is a folder with videos, it is already mounted and working. My query now is how can I automate it so that when I restart the nas, they are remounted ?.

You'd enable the systemd service to start at boot

systemd enable service

Good morning, what would it be, to create a script?

What's your Operating System / Device?

Device is a Qnap 451+ os / arch: linux / amd64

I’m a Linux guy so sorry as I can’t help you automate that. Perhaps someone with more QNAP knowledge can chime in.

Nothing partner, thank you very much for the help you have given me.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.