Rclone IO errors after few minutes?

What is the problem you are having with rclone?

rclone (running in vm idk if that changes anything) works fine for a few minutes but when used after a while everything locks up and gives me IO errors. I am unsure as to why its working just fine then starts giving me errros. I am running rclone inside Windows server 2019 running off a VM using Proxmox I set it up as I did on my personal computer and even the same server back when it was running windows server 2019 on bare metal. I don't understand why this is happening now, I haven't changed any versions or the command or anything, its all the same but it gives me IO errors after a while and I don't know why. I don't have logs as I don't how to use it properly I tried this (rclone --log-file=mylogfile.txtx --log-level DEBUG) commend I found here How to generate log file for rclone? but all i get is

2022/01/02 09:49:45 DEBUG : rclone: Version "v1.53.1" starting with parameters ["rclone" "--log-file=mylogfile.txt" "--log-level" "DEBUG"]

nothing else happens :confused:

What is your rclone version (output from rclone version)

v1.53.1 (the same version I'm using and successfully running and working just perfectly on my Main PC and has been working for all my other pc's except now)

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

mount --allow-other --dir-cache-time 72h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off Gdrive: X: --config "C:\Users\Administrator\.config\rclone\rclone.conf" --vfs-cache-mode writes

The rclone config contents with secrets removed.

type = drive
client_id = 
client_secret = 
scope = drive
token = {"I'm not sure if this token should have been removed or not but gonna assume so"}

A log from the command with the -vv flag

Sadly idk how to use it since i don't know how to use rclone I just know what a guide told me to get it to work how i wanted it


  1. for debug log, change --log-level INFO to --log-level DEBUG
  2. we cannot see into your computer, so gives me IO errors, no idea what that means???
  3. best to update to latest rclone, v1.57.0
  4. most likely something to do with your particular setup, not rclone.

which is it?

  1. you have been running the vm for a long time and just now have issues
  2. this is a new vm and it has never worked?
  1. I did set it to DEBUG not INFO as I said in my post the command I ran.
  2. I can see my computer but it just says IO errors it doesn't say anything else so we are in the same boat.
  3. I updated and same results sadly.
  4. I'm not entirely sure because I set it up the same as any other device and its just a windows server 2019 install on a vm (Its worked on 2019 win server before plenty of times on multiple machines. the same exact steps everytime)

Its a brand new VM I started and im having this issue. but I've had rclone mount the disk and it never gave me this issue on multiple installs on my hardware following the same steps for example the exact same steps work on my pc but not in the vm?

I updated rclone and it seems to be working so far. I have no idea why it works on updated when the none updated versions work fine on my other computers?

nothing happens because there is no action verb, copy/sync/mount

good it is working, but without debug logs, i cannot tell you why.
or the problem had nothing to do with rclone and was some issue with your system.
for example, i ran into this problem, where sometimes, rclone would take hours to upload large file veeam backup files.
after a lot of debugging with the event viewer, i figured out that on the window server, was using the awesome refs file system with data integrity is enabled.
so once a month, windows runs a task that does a data integrity validation/check on the entire file system. as refs is soft-raid, that slowed down the server severely.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.