Rclone ignoring modified time? Wasabi s3

Anyone else notice rclone copy has a habit of only looking at size and not modified time on Wasabi? rclone v1.60.1

Below is an example. Two files. a "repo" file and a "repo.sha256" file. I was getting complaints of our repo file not passing sha256 checksumming.

2022-12-04 19:50:30 DEBUG : x86_64/r1~beta4_hrev56578_46/repo.sha256: Sizes identical
2022-12-04 19:50:30 DEBUG : x86_64/r1~beta4_hrev56578_46/repo.sha256: Unchanged skipping
*             x86_64/r1~beta4_hrev56578_46/repo:100% /2.375Ki, 0/s, -

our build pipeline creates the repo file, and then checksums it, then does an rclone copy of it to wasabi s3. I run through the build, and it creates the artifacts.

I run through the build a second time (generating a new repo file and checksum) and rclone only seems to update the repo file (which likely changed in size), but not the repo.sha256 file (which is expectantly the same size).

I just added the -c to try and do md5sum checking and am testing it now. However, it seems weird to me that the modified time checks aren't working. I checked the container vs the time of the s3 files, and they definitely differ. (though folders have a 1969 date @ wasabi)

rclone -vv copy ./directory/  remote:/another/directory/

sigh. nevermind. Thanks to rclone for printing out the command line flags when -vv is passed.

The "resource" i found for our ci/cd implementing rclone makes a really bad assumption...

:sob: that too way too long to debug lol.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.