Rclone High CPU Utilization

What is the problem you are having with rclone?

I have a mount set up with Aws S3.
I'm creating a file on the mounted drive every sec programmatically, which means 60 files in a min, 300 files in 5 mins.
When it reaches 200 files itself , the cpu usage shoots up to around 97-100%.
Please refer the image below.
Is there any configuration to improve the performance.

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: Microsoft Windows 10 Enterprise 21H2 (64 bit)
  • os/kernel: 10.0.19044.2728 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rcd
"mountPoint": "S:",
"LogLevel": "INFO",
"CacheMode": "full",
"FilePerms": 511,
"DirPerms": 511,
"ChunkSize": "16M",
"DirCacheTime": 60000000000
"VolumeName": "driveupload"

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

Sounds like something has gone wrong...

I suggest you follow the profiling tips here: Remote Control / API and see if you can figure out what is using the CPU.

A log (with -vv) will also show useful info - probably bets to look at that first.

Aside: @albertony - why does is rclone identifying as "Rsync for cloud storage" in the above screenshot - did we get some of the .exe info wrong?

Hm, yes, the windows task manager "Processes" list is showing the "File Description" info from the binary resource (while the "Details" list, which is normally what I use myself, shows the file name "rclone.exe"). The string was taken from the "About" section of the GitHub page. Seems better to just have "Rclone" there as well, I'll fix that.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.