Rclone has been banned from Amazon Drive

Sorry! It did worked!!!
YOU CANT USE AUTH FROM ANOTHER APP.

First.
Use clouddrive to generate the token.

Second
Manual edit your .conf file and paste in “token” parameter.
[cloudname]
type = amazon cloud drive
client_id =
client_secret =
token = {paste here}

It worked for me.

OBS: Yes… thats not really safe. The third party server could record that. But it can work as a temporary solution to tranfer files.

@amunhoz Note that you’ll hit an issue when the token comes to be refreshed; rclone doesn’t know to hit the clouddrive refresh service to get the new token so will fail (in my tests it causes a panic).

But as long as you’re willing to manually refresh the token entry then, yes, rclone will talk to ACD for a short while.

Agreed… So, if anyone need to transfer the files out Amazon, they can use this solution for a whyle.

1 Like

@sweh So, the perfect solution is to have your own key for api.
Do you have any idea how to get it?

Okay thanks ans how Long is one token Active before a refresh is necessary?

This is the information in the token “expires_in”:3600, but i dont know if it is minutes or seconds.
If it keep the same token after renew, you can run the original app in paralel to make it renewed as a temporary solution.

@amunhoz Amazon are not allowing any new developers to sign up and get their own API key at the moment:

https://developer.amazon.com/amazon-drive

The Amazon Drive API and SDKs are currently closed to new developers.
Thank you for your interest. We received an overwhelming number of API invitation requests with many innovative integration scenarios. We have ended the invitation period to focus on enabling new customer experiences with current developers.

3600 seconds, or one hour.

As an emergency solution to access data stored on ACD, I’ve tried drivesink as someone else pointed out before, and it works.

Here is the Linux install procedure:

sudo su
cd /usr/local/bin
chmod +x ./drivesink.py
sudo apt-get install python-pip
pip install --upgrade pip
pip install requests
pip install requests-toolbelt
exit

Download DriveSink using:

sudo wget https://raw.githubusercontent.com/caseymrm/drivesink/master/drivesink.py -O /usr/local/bin/drivesink.py

To configure drivesink go to:

https://drivesink.appspot.com/config

then copy the token to ~/.drivesink

Now you can download your precious data using:

 drivesink.py download /acd_folder_name /local/path

Encrypted data can then be decrypted (after download) using rclone encryption of a local folder.

Tested on Debian and Ubuntu servers; should work out-of-the-box with Mac too

1 Like

This incident made it to heise (german tech news)

2 Likes

After downloading data via Drivesink, am I obliged to decrypt and rencrypt everything before sending to a new server? Or lets say if I just upload the data to Hubic, the way it is, I could use the same password/key in Hubic? Also, I was wondering if I could mount a Hubic drive via rclone, for example, in my server, and then download all the data directly to my mounted drive, via drivesink. Instead of saving everything to an internal hard drive first.

Yes, you can mount HubiC as a drive via rclone, even if it’s less “robust” than ACD was; moreover the total upload/download speed is 10Mbps, doesn’t matter how many connections you do.

Well… I just got this response from Amazon…

They explicitly say they will not be reenabling access to Rclone.

Hello,

I’ve checked with our appropriate teams and wanted to let you know that I’ve received a response, and they indicated your issue that we will not be re-enabling access to Amazon Drive from Rclone. Please accept my sincere apologies for any inconvenience.

They go on saying we ca discuss this in the appropriate forum and the dev team is listening to our suggestions…

A shame really…

Thanks a lot for the info. This is really absurd.
So, I will now play the dirty game, I will buy some ebay Unlimited GDrive accounts and transfer everything to those accounts. As I will have multiple copies, data safety won’t be a problem.

I had setup my own developer and can get my own access token and write it to rclone.config.
How can I patch rclone so that instead of asking for new token, it will read it from the config file again?

You had a access token from long time ago? Because it is not possible to get access tokens nowadays.

Yes I had a test app…

Thank you for the guide. I keep getting the following though:

syntax error near unexpected token ‘newline’
`DOCTYPE html’

This is what I did to install:

curl -O https://github.com/caseymrm/drivesink/blob/master/drivesink.py

  • Your guide. Any help is appreciated.

Exact same problem here with drivesink

syntax error near unexpected token ‘newline’
`DOCTYPE html’

Would be very grateful if any one could help get this working as I’m struggling to get my data off of acd.

The problem is I need to get my data from ACD onto my server since my home connection is slow. I was looking at odrive but don’t know if that would work to get my files from the cloud to the FTP. If anyone has any ideas or suggestions, I’d appreciate the help. Cheers.