RClone GUI on ShinyProxy

What is the problem you are having with rclone?

Attempting to use Rclone Web GUI in ShinyProxy. Have tried a few solutions, the best so far is using --rc-addr and launching container with port 5572.

The Web GUI "Something went wrong" screen appears.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rcd --rc-web-gui --rc-addr= --rc-no-auth -vv

(--rc-no-auth used because already logged in via ShinyProxy)

For those familiar with ShinyProxy application.yml:

- id: rclone
      display-name: RClone
      container-image: rclone/rclone
      container-cmd: ["rclone rcd --rc-web-gui --rc-addr= --rc-no-auth -vv"]
        - "${PWD}/.rclone/config:/config"
      port: 5572

(This is a simplified version of the application.yml, can do a full reprex if that is needed)

I tried the instructions at GUI (e.g. ShinyProxy is hosted at localhost:8080 so --rc-addr localhost:8080 and container for Rclone was served at localhost:8080/app/rclone so --rc-baseurl "/app/rclone") but they didn't work as well as the solution above.

A log from the command with the -vv flag

2023/05/04 07:10:43 DEBUG : rclone: Version "v1.62.2" starting with parameters ["/usr/lib/rclone" "rcd" "--rc-web-gui" "--rc-addr=" "--rc-no-auth" "-vv"]
2023/05/04 07:10:44 ERROR : Error reading tag file at /root/.cache/rclone/webgui/tag 
2023/05/04 07:10:44 DEBUG : Current tag: , Release tag: v2.0.5
2023/05/04 07:10:44 INFO  : A release (v2.0.5) for gui is present at https://github.com/rclone/rclone-webui-react/releases/download/v2.0.5/currentbuild.zip. Use --rc-web-gui-update to update. Your current version is ()
2023/05/04 07:10:44 NOTICE: A new release for gui (v2.0.5) is present at https://github.com/rclone/rclone-webui-react/releases/download/v2.0.5/currentbuild.zip
2023/05/04 07:10:44 NOTICE: Downloading webgui binary. Please wait. [Size: 4763452, Path :  /root/.cache/rclone/webgui/v2.0.5.zip]
2023/05/04 07:10:45 NOTICE: Unzipping webgui binary
2023/05/04 07:10:45 NOTICE: It is recommended to use web gui with auth.
2023/05/04 07:10:45 NOTICE: Serving Web GUI
2023/05/04 07:10:45 NOTICE: Serving remote control on http://[::]:5572/

A few updates after some more testing:

Error after logging into ShinyProxy

After clicking into the container, the following error is shown:

{status: "error", message: "shinyproxy_authentication_required"}
  message: "shinyproxy_authentication_required"
  status: "error"

So it looks like it's expecting ShinyProxy authentication even though I have already logged in?

Using docker network

The same issue occurs when using both ShinyProxy and the RClone GUI on a docker network:

    image: shinyproxy_shinyproxy:latest
    restart: always
      - 8080:8080
      - rclone
      - '/var/run/docker.sock:/var/run/docker.sock'
      - "./application.yml:/opt/shinyproxy/application.yml:z"
      - USER=${USER}
      - USERID=${USERID}

    image: rclone/rclone
    restart: always
    command: rcd --rc-web-gui --rc-addr --rc-no-auth
      - /home/jsmith/docker/rclone_rclone:/config/rclone
      - /home/jsmith/docker/rclone_rclone:/logs
      - 5572:5572
      - PUID=1000
      - PGID=1000

At least I can see the GUI dashboard home page with a docker network solution but clicking any buttons causes the same error to occur.

Another alternative is to host the rclone server in the docker network then use the rclone config commands. For example, I can access a Visual Studio Code Server with rclone installed within ShinyProxy. I can get to the point of authenticating a OneDrive rclone connection but the following authentication link doesn't work:

2023/05/08 07:50:16 NOTICE: If your browser doesn't open automatically go to the following link:
2023/05/08 07:50:16 NOTICE: Log in and authorize rclone for access
2023/05/08 07:50:16 NOTICE: Waiting for code...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.