Rclone GUI not updating

Hello all,

I have rclone working successfully in Docker with web GUI accessible. However, the GUI does not update with current copy processes started using the CLI.

My docker-compose is:

version: '3'

image: rclone/rclone:latest
container_name: rclone
restart: unless-stopped
command: rcd --rc-web-gui --rc-addr :5572 --rc-web-fetch-url=https://api.github.com/repos/rclone/rclone-webui-react/releases/latest --rc-web-gui-update --rc-user james --rc-pass rclone
- "5572:5572"
- /docker/rclone:/config/rclone
- /docker/rclone/logs:/logs
- /freenas:/freenas
- /docker/rclone/sync_script:/sync_script
- PHP_TZ=Europe/London

external: true

Is there something that I am missing? Perhaps a permission issue? It would be great to be able to have automated backups running with a simple web gui to view progress. Thanks in advance.

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

Hello @Animosity022

Thanks for your reply. I am using the latest version of rclone and rclone gui (1.52.3 & 2.0.3).

This is running on an Alpine VM (latest version - 64bit).

Using Google Drive.

Config: (redacted)
type = drive
scope = drive
token = {"access_token":"my token"}
client_id = client id
client_secret = my secret
root_folder_id = root folder

type = crypt
remote = GoogleDrive:/
filename_encryption = standard
directory_name_encryption = true
password = password
password2 = password2

I don't appear to have any logs and cannot get them to write to folder :confused:

Change your command to have -vv --log-file rclone.log

And share the logfile.

Thanks @Animosity022 I have added that, checked all permissions (fine) and it will not generate a log. Any ideas?

You'd have to share some more info as to what you typed, what you run, an error screenshot, etc.

Perhaps I just misunderstand what the GUI is. My understanding is that you can control the daemon (on a docker VM in my case) with the web GUI.

I assume that you run rclone container with a config that starts the web GUI and a copy command, and that you can view the progress through the browser? Is that correct?

So far I can run the gui (but not a copy command at the same time) and view it on another PC. When I then run a copy command with the gui already online nothing happens? I assume it's spinning up another daemon. What I'd like is to run the gui and copy command and view it in real time.

Is that possible?

It all depends on what you want to do.

If you start up the GUI and the RCD, you can monitor jobs that you submit to it.

You'd have to share the copy command you are running as it's hard to understand what you are doing without sharing the specific details.

Thanks for your continued time @Animosity022

I start my container with:

version: '3'

image: rclone/rclone:latest
container_name: rclone
- no-new-privileges:true
restart: unless-stopped
#user: 500:501
command: rcd --rc-web-gui --rc-addr :5572 --rc-web-fetch-url=https://api.github.com/repos/rclone/rclone-webui-react/releases/latest --rc-web-gui-update --rc-user james --rc-pass rclone -vv --log-file rclone.log
- "5572:5572"
- /docker/rclone/logs:/logs
- /freenas:/freenas
- /docker/rclone/config:/config/rclone
- /docker/rclone/sync_script:/sync_script
- PHP_TZ=Europe/London

external: true

This allows me to access the GUI at the above IP. Configs etc are all working.

When I log into the container and run:

rclone copy --checksum --verbose --transfers 1 --checkers 4 --contimeout 60s --timeout 300s --retries 3 --low-level-retries 10 --stats 1s /freenas GoogleDrive_NAS_crypt:NAS

The copy process begins within the command line (files are uploading normally) but the GUI does not show any activities.

Ah, that helps as that make sense.

The remote control daemon is like a server if you think of it in that regard and the GUI sits on top of the server.

The only way to get things to show up is you have to submit jobs to it. You ran the command and basically launched up another rclone and that's why you don't see it.

You'd want to submit something to the server via the RC daemon to see it show up in the GUI:


Thanks for that @Animosity022 - Could you give an example for what I am trying? I'm not sure that I follow the logic here.

Am I submitting the call to API via the daemon's IP address?

Let me see if I can dig up an actual copy command as i just use a refresh:

/usr/bin/rclone rc vfs/refresh recursive=true --rc-addr _async=true

Perfect, thanks so much for this. Could you just confirm the syntax?

So something like this but I am not running with auth so I get a 403, I'd have to fix that later by adding --rc-no-auth to my mount:

felix@gemini:/etc/systemd/system$ rclone rc sync/copy srcFS=/etc/hosts dstFs=GD: --rc-addr
2020/08/17 20:18:49 Failed to rc: Failed to read rc response: 403 Forbidden: {
	"error": "authentication must be set up on the rc server to use \"sync/copy\" or the --rc-no-auth flag must be in use",
	"input": {
		"dstFs": "GD:",
		"srcFS": "/etc/hosts"
	"path": "sync/copy",
	"status": 403

As an example.

Thanks for all of your help. Appreciate it.

One last question @Animosity022 - Can the srcFS be on the docker container itself? If so, how do I reference that? I have mounted my NAS to my container as a volume.

I don't use dockers so I'm not that familiar with them.

the srcFS is relative to rclone so if rclone is running in the container, I don't think so.

You'd have to run rclone outside the container to point to the whole container I'd think.

I have mounted my FreeNAS to /freenas within the container and I can view the files. I'm currently running:

rclone rc sync/copy srcFS=/freenas dstFs=GoogleDrive_NAS_crypt:NAS --rc-addr= --rc-user= james --rc-pass=rclone _async=true

But it doesn't seem to be working. From logs:

2020/08/18 11:18:13 DEBUG : rc: "operations/list": with parameters map[fs:freenas: remote:]

2020/08/18 11:18:13 DEBUG : fs cache: switching user supplied name "freenas:" for canonical name "freenas:/data"
2020/08/18 11:18:13 DEBUG : rc: "operations/list": reply map[list:[0xc00009a270 0xc00009a410]]:
2020/08/18 11:18:15 DEBUG : fs cache: switching user supplied name "freenas:" for canonical name "freenas:/data"

I'm not really sure what that means. The dashboard does then start to show a graph but the speeds are ridiculous compared to my upload speed of 20Mbps (it's showing 90MBps...)

It also doesn't show the current file/progress of the upload :confused:

I do receive a jobID but nothing happens.

Update - 3 hours later: Still unable to have anything show on the dashboard, let alone actually upload something. Even if I run the upload rc command on the container itself it doesn't work. I receive a job id but it does nothing.

OK @Animosity022 scrap docker - I cannot even get this to work locally.

I run rclone with:
rclone rcd --rc-web-gui --rc-addr :5572 --rc-web-fetch-url=https://api.github.com/repos/rclone/rclone-webui-react/releases/latest --rc-web-gui-update --rc-user james --rc-pass rclone -vv --log-file rclone.log

and then run the command as:

 rclone rc sync/copy srcFS=Z:/ dstFs=GoogleDrive_NAS_crypt:NAS --rc-addr=:5572 _async=true --rc-user=james --rc-pass=rclone

I receive a job id but nothing happens... There is no upload. Pulling my hair out here.

You should see something like this as an example:


rclone rcd --rc-web-gui -vv --rc-addr

My command:

rclone rc sync/copy srcFs="/home/felix/test" dstFs="GD:test" --rc-user felix --rc-pass felix -vv

My GUI Window showing a transfer.