Rclone GUI: Issues with mount point

I started the rclone container as follows:

docker run -d --name='rclone-gui' --net='bridge' -e TZ="Europe/Berlin" -e HOST_OS="Unraid" -e 'PUID'='99' -e 'PGID'='100' -p '5572:5572/tcp' -v '/mnt/user/appdata/rclone/config':'/config/rclone':'rw' -v '/mnt/user/web':'/data/web':'rw' -v '/mnt/cache/appdata/rclone/remotes':'/data/remotes':'rw' --device='/dev/fuse' --cap-add SYS_ADMIN --security-opt apparmor:unconfined 'rclone/rclone' rcd --rc-web-gui --rc-addr :5572 --rc-user john --rc-pass password --rc-web-gui-no-open-browser

Important part:
container's "/data/remotes" points to host's "/mnt/cache/appdata/rclone/remotes"

Adding a mount
After adding a config through the GUI I tried to add a mount. Issues:

  1. I tried to add the mount point "/data/remotes/foo" for my remote. As "foo" does not exist the GUI returned an error 500. Suggestion: It would be nice if the error would be more clear like:

"/data/remotes/foo" does not exist

  1. As its a GUI: Wouldn't it be better if it creates "/data/remotes/foo" automatically (or by additional confirmation dialog)?
  2. I executed "mkdir /data/remotes/foo" and now I was able to add the mount point. I executed "ls /data/remotes/foo" which returns my remote files, but executing "ls /mnt/cache/appdata/rclone/remotes/foo" on the host, returns nothing. Isn't it possible to add mounts which are accessible outside of the container?
  3. I restarted the container. While the configs are still there, the mount points are gone. Isn't it possible to make them persistent?

There was almost certainly an nice error message in the 500 error - did the GUI not display it? If not then I suggest you make an issue here: Issues · rclone/rclone-webui-react · GitHub

An additional message might be nice.

You need to add the :shared tag to your mount line if you want that - see the example here: Install

That is a bit harder as the webgui is stateless, so it would have to be rclone doing that.