Rclone google drive crypt error

I am getting an error when setting up rclone + cache + crypt

I have followed this guide, tried several times -https://bytesized-hosting.com/pages/rclone-gdrive

The specific error I’m getting is:
2019/03/16 00:40:47 NOTICE: Encrypted drive ‘gcrypt:’: ChangeNotify was unable to decrypt “Media”: not a multiple of blocksize

Media is a subfolder in the root of google drive, I have another subfolder inside Media, Music with one mp3 inside.

I have 3 remotes drive, crypt and cache:

type = cache
remote = gdrive:Media
chunk_size = 5M
info_age = 1d
chunk_total_size = 10G

type = crypt
remote = gcache:/crypt
filename_encryption = standard
directory_name_encryption = true
password = *** ENCRYPTED ***
password2 = *** ENCRYPTED ***

type = drive
scope = drive
token = {“access_token”:REMOVED,“token_type”:“Bearer”,“refresh_token”:REMOVED,“expiry”:“2019-03-16T01:38:40.920722484+01:00”}

I’m very new to this so any help would be greatly appreciated.

Normally, you’ll have your “gdrive” remote, which you have.

You’ll make a cache of the gdrive so remote would be:

remote = gdrive:

In your root google drive, you have a folder called “media” or “crypt”?

If it was media, you’d have gcrypt point to:

remote = gcache:media

and I’m assuming that’s the folder you want encrypted.

that’s right in google drive I have a folder called Media which is the folder I want encrypted I’ll try remote = gcache:media and get back to you with the results.

Thanks for responding!

@Animosity022 I think I made the changes you suggested but unfortunately after trying the mount command I’m receiving the same error.

The changes I made:
type = crypt
remote = gcache:/Media
filename_encryption = standard
directory_name_encryption = true
password = *** ENCRYPTED ***
password2 = *** ENCRYPTED ***

Mount command I’m running:
rclone mount --allow-other --allow-non-empty gcrypt: ~/mnt/gdrive &

What does this show?

rclone ls gdrive:Media

Yeah I tried that command a few hours ago. I get back the correct contents of the folder:

2403055 Music/01 Soupir Articulé.mp3

That means you didn’t encrypt anything and it’s a regular folder.

My example

[felix@gemini ~]$ rclone lsd GD:media
          -1 2018-06-30 12:55:49        -1 d93daonsmv845k5s40knr5mf4s
          -1 2018-06-17 09:16:39        -1 s1n6gn87oo537vvls13nahl6co
          -1 2017-04-18 16:14:26        -1 smu5ej34ujbdoip1cm3mlk92q4
          -1 2018-06-17 10:24:02        -1 tnvepu36qiohcun8v84ddhsam0
[felix@gemini ~]$ rclone lsd gcrypt:
          -1 2018-06-17 10:24:02        -1 Movies
          -1 2018-06-17 09:16:39        -1 Radarr_Movies
          -1 2017-04-18 16:14:26        -1 TV
          -1 2018-06-30 12:55:49        -1 TV_Ended

So the crypt mount is showing an error because unencrypted files are there.

Ok I’m probably going to ask a really dumb question now. I thought the guide I mentioned in my original question would encypt the files in my google drive and read them for plex?

If this is the case am I doing something wrong further up?

How did you move the files to that location?

I just copied them over from my desktop to the google drive folder

The way rclone encryption works is that you have to use rclone to do the encryption.

If you drag/drop a file there, it won’t work as you aren’t using rclone so it cannot encrypt it.

You can either copy to the mount directly or use rclone copy commands to it.

The way that guide is setup though, you’d want to copy on the mount as it uses the cache backend and only one process at a time can access the cache.

ah ok that makes sense. Thanks for explaining.

I think I’ve got enough to go on to take another shot at it.


One thing that may help as you can make another remote just pointing the encrypted location and use that for rclone copy/move commands.

I’ll give that a go. Thanks again!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.