Rclone GDrive transport endpoint is not connected

I have recently moved away from ACD to Google Suits unlimited offering as my cloud storage provider, I have moved everything over and added a lot more stuff.

I have been getting a transport endpoint is not connected, I am not 100% as to what is causing it to break as it does it at random times throughout the day, I have had it break when streaming via plex or when uploading and when nothing is going on at all. I have tried disabling ufw for a short time to see if the firewall was causing issues but it still exists.

OS: Ubuntu 16.04.1

If anyone has any ideas as to what could be causing this then please feel free to comment below, I have been looking into trying to setup a cron job to check if the drive is mounted and then act accordingly from there but I am not the best with bash scripting.

To figure out exactly what’s going you’ll need to post some logs. In the meantime you could use a script to check if Google is mounted and remount it if it’s not.


if [ $(ls -l ~/path/to/remote | grep -v ‘^total’ | wc -l) -gt 0 ]; then
echo “still mounted”
echo “remote not mounted, remounting”
rclone mount remote:

just make a cron job with that script to check it every so often.

That is a networking error.

This might be something to do with the persistent http connections being closed. That could be your computer, router, ISP or maybe even google.

Some logs would be helpful.

Hey. I got the same Problem with GDrive. Tried with root to be sure it’s not permissions problems.
Strange thing is, only new created folders works for mounts. As soon as i have had connected rclone with a folder, it won’t work anymore for the next time.

root@uBox:~# sudo chmod u+s /bin/fusermount
root@uBox:~# sudo rclone mount secret: /media/snikay/Drive4/test6
2017/07/16 16:54:09 mount helper error: fusermount: failed to access mountpoint /media/snikay/Drive4/test6: Transport endpoint is not connected
2017/07/16 16:54:09 Fatal error: failed to mount FUSE fs: fusermount: exit status 1
root@uBox:~# mkdir /media/snikay/Drive4/test7
root@uBox:~# sudo rclone mount secret: /media/snikay/Drive4/test7

i’ll post logfiles soon

1 Like

Had the same problem.

The command:
fusermount -u /path/which/you/want/to/mount
fixed it.