Rclone + GDrive + Plex not auto-updating my library and help with plex_rcs

Lately, I have find out that my Plex library is not auto-updating even if the first two checks in Plex settings for the library are enabled.

I'm using Rclone to map a GDrive to my Plex server that runs on Ubuntu. Here is my rclone mapping options :

ExecStart=/usr/bin/rclone mount
--log-level INFO
--buffer-size 16M
--dir-cache-time 72h
--drive-chunk-size 32M
--vfs-read-chunk-size-limit off
--vfs-read-chunk-size 128M Plexdrive: /home/plexserv/Plexdrive

I tried configuring plex_rcs but when I'm at the edit plex_rcs.service file, there is no file found in the package or no file found under /etc/systemd/system to configure this service properly.

What is the best thing to do to make Plex auto-update once a new file is detected inside rclone?


What version of rclone are you running?

There's no need for really using plex rcs as polling changes are picked by default every minute.

When I type rclone version, it shows 1.50.2

I just modified the target of my library. I will see if it helps.

No I tested and downloaded some stuff. The library didn't updated themselves.

I am not sure what you mean.

You upload a file somewhere else and you aren't seeing on it on the mount ?

The plex libraries aren't auto updating?

Can you give an example of what you are doing?

What's your rclone.conf look like without the keys/passwords?

Can you share a debug log of the mount and re-create the issue?

I download a video file and drop it inside the rclone mounted drive. Linked Plex do not auto-update it.

As for the log, I can't currently because I'm 8h road far from my home but I will be back in 3 days.

Do you mean you don't see on the mount? Still not really clear.

No, I see it on the mount without problems. Plex library listing do not auto update it's listing when the file is there.

You need to use something like:

Plex won't autodetect it.

Thanks. I installed it. I struggle getting the rigths because when I try condfigure the config.json, it says I don't have rights. I have done this. I will figure out later.

root@PLEXSERV:/opt# id
uid=0(root) gid=0(root) groupes=0(root)
root@PLEXSERV:/opt# sudo chown -R plexserv:root plex_autoscan

bash: /opt/plex_autoscan/config/config.json: Permission non accordée

plex_rcs was broken, even in the forks.

I fixed the issues and added windows support too.

You need to set log-level to DEBUG (until my PR is merged in and released)
You must set a log-file, can't use syslog.

Thanks a lot, I will test it.

So basically, I have done the next things:

  • git clone https://github.com/beyondmeat/plex_rcs.git
  • pip3 install -r requirements.txt
  • Copy the config.yml.default to config.yml
  • Edit config.yml to include your X-Plex-Token, set your media_root setting and any other settings. See below for more information on the media_root setting . Media Root = /home/plexserv/Plexdrive
  • Configure the service like this :

Using systemd

  1. Edit the included plex_rcs.service file and change the path to where the plex_rcs.py file is located
  2. Copy the systemd file to /etc/systemd/service : sudo cp plex_rcs.service /etc/systemd/service
  3. Reload systemd: sudo systemctl daemon-reload
  4. Enable the service [auto-starts on boot]: sudo systemctl enable plex_rcs
  5. Start the service: sudo systemctl start plex_rcs
  • Changed my Plex logggin to loglevel DEBUG with a target for the log file.

My Plex_rcs still do not work like intended and Plex is not updated once a file is added.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.