Rclone from Google Drive - fails to open files in e.g. Word

What is the problem you are having with rclone?

I'm attempting to see if I can use rclone to replace Google Drive Desktop on my Surface Pro 11, which has an ARM processor; Google Drive Desktop refuses to install due to the architecture. I have successfully mounted the team shared drives I have access to on Google to Windows drive letters. However, when I try to open a file with e.g. Word, I get the following error:

"Word had trouble reading from your file (filename.docx). If you are trying to access a file not on your hard drive, please check your internet connection or removable storage and retry."

I certainly understand that this may be a fundamental limitation of rclone. However, I wanted to make sure I wasn't missing something, or if there might be a workaround.

I can copy the file in File Explorer locally and open it fine.

Run the command 'rclone version' and share the full output of the command.

rclone v1.67.0
- os/version: Microsoft Windows 11 Home 24H2 (64 bit)
- os/kernel: 10.0.26100.1000 (aarch64)
- os/type: windows
- os/arch: arm64 (ARMv8 compatible)
- go/version: go1.22.4
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe mount drive1: x:

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[drive1]
type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = XXX
root_folder_id =

[drive2]
type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = XXX
root_folder_id =

[drive3]
type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = XXX
root_folder_id =

A log from the command that you were trying to run with the -vv flag

(in process)

hi, to use rclone, there has to be a command. perhaps rclone mount

run the command with -vv
or
use a log file --log-level=DEBUG --log-level=c:\path\to\rclone.log

1 Like

Yeah, it's already mounted though at the point of failure, but I suppose I wasn't clear on the intention. I'll try the log - will that log all actions that occur while it is mounted?

post the exact command.

the debug setting will log all actions.

1 Like

rclone.exe mount drive1: x:

in general, to edit files, need to use --vfs-cache-mode
perhaps try --vfs-cache-mode=full

That did it, thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.